Zerene Stacker

Differences

This shows you the differences between two versions of the page.

stacker:docs:faqlist [2012/07/10 02:12]
rjlittlefield [What are the differences between Personal and Professional?]
stacker:docs:faqlist [2014/12/21 00:17] (current)
rjlittlefield
Line 5: Line 5:
 **Purchasing** **Purchasing**
  
-  * [[#what_are_the_differences_between_personal_and_professional|What are the differences between Personal and Professional?]]+  * [[#what_are_the_differences_between_personal_prosumer_and_professional|What are the differences between Personal, Prosumer, and Professional?]]
   * [[#i_see_some_menu_items_labeled_pro__what_does_that_mean|I see some menu items labeled (Pro). What does that mean?]]   * [[#i_see_some_menu_items_labeled_pro__what_does_that_mean|I see some menu items labeled (Pro). What does that mean?]]
 +  * [[#are_program_updates_free|Are program updates free?]]
   * [[#do_i_have_to_pay_more_to_get_64-bit_mode|Do I have to pay more to get 64-bit mode?]]   * [[#do_i_have_to_pay_more_to_get_64-bit_mode|Do I have to pay more to get 64-bit mode?]]
   * [[##i_m_upgrading_my_computer_do_i_have_to_buy_a_new_license|I'm upgrading my computer.  Do I have to buy a new license?]]   * [[##i_m_upgrading_my_computer_do_i_have_to_buy_a_new_license|I'm upgrading my computer.  Do I have to buy a new license?]]
   * [[#i_have_both_a_mac_and_a_pc_do_i_need_two_licenses|I have both a Mac and a PC.  Do I need two licenses?]]   * [[#i_have_both_a_mac_and_a_pc_do_i_need_two_licenses|I have both a Mac and a PC.  Do I need two licenses?]]
   * [[#can_i_purchase_the_software_on_cd|Can I purchase the software on CD?]]   * [[#can_i_purchase_the_software_on_cd|Can I purchase the software on CD?]]
 +
 +** Installing and Updating **
 +
 +  * [[#how_do_i_download_and_install_the_program|How do I download and install the program?]]
 +  * [[#i_bought_a_license_how_do_i_install_it|I bought a license, how do I install it?]]
 +  * [[#how_can_i_update_the_program|How can I update the program?]]
 +  * [[#can_i_have_multiple_versions_installed_at_the_same_time|Can I have multiple versions installed at the same time?]]
 +  * [[#do_you_have_a_beta_test_channel|Do you have a "beta test" channel?]]
  
 **File Formats** **File Formats**
  
 +  * [[#will_zerene_stacker_work_with_my_camera|Will Zerene Stacker work with my camera?]]
   * [[#what_kinds_of_image_files_will_zerene_stacker_handle|What kinds of image files will Zerene Stacker handle?]]   * [[#what_kinds_of_image_files_will_zerene_stacker_handle|What kinds of image files will Zerene Stacker handle?]]
   * [[#does_zerene_stacker_handle_raw_files|Does Zerene Stacker handle raw files?]]   * [[#does_zerene_stacker_handle_raw_files|Does Zerene Stacker handle raw files?]]
Line 22: Line 32:
 **Shooting Stacks** **Shooting Stacks**
  
 +  * [[#does_zerene_stacker_help_me_to_shoot_a_stack|Does Zerene Stacker help me to shoot a stack?]]
   * [[#does_zerene_stacker_correct_for_changes_in_magnification_as_i_focus|Does Zerene Stacker correct for changes in magnification as I focus?]]   * [[#does_zerene_stacker_correct_for_changes_in_magnification_as_i_focus|Does Zerene Stacker correct for changes in magnification as I focus?]]
   * [[#does_it_matter_if_i_shoot_the_stack_in_order|Does it matter if I shoot the stack in order?]]   * [[#does_it_matter_if_i_shoot_the_stack_in_order|Does it matter if I shoot the stack in order?]]
 +  * [[#does_it_matter_if_i_work_front-to-back_or_back-to-front|Does it matter if I work front-to-back or back-to-front?]]
 +  * [[#do_i_need_a_focus_rail|Do I need a focus rail?]]
 +  * [[#how_do_i_figure_out_what_aperture_setting_and_step_size_to_use|How do I figure out what aperture setting and step size to use?]]
  
 **Stacking** **Stacking**
Line 35: Line 49:
   * [[#what_is_the_difference_between_pmax_and_dmap|What is the difference between PMax and DMap?]]   * [[#what_is_the_difference_between_pmax_and_dmap|What is the difference between PMax and DMap?]]
   * [[#how_should_i_choose_those_dmap_settings|How should I choose those DMap Settings?]]   * [[#how_should_i_choose_those_dmap_settings|How should I choose those DMap Settings?]]
 +  * [[#should_i_sharpen_before_or_after_running_zerene_stacker|Should I sharpen before or after running Zerene Stacker?]]
   * [[#how_can_i_detect_movement_in_my_stack|How can I detect movement in my stack?]]   * [[#how_can_i_detect_movement_in_my_stack|How can I detect movement in my stack?]]
 +  * [[#why_did_the_software_reverse_the_order_of_my_images|Why did the software reverse the order of my images?]]
   * [[#can_i_directly_control_the_order_that_images_are_processed|Can I directly control the order that images are processed?]]   * [[#can_i_directly_control_the_order_that_images_are_processed|Can I directly control the order that images are processed?]]
   * [[#why_do_my_saved_output_images_look_washed_out|Why do my saved output images look washed out?]]   * [[#why_do_my_saved_output_images_look_washed_out|Why do my saved output images look washed out?]]
Line 47: Line 63:
 **Miscellaneous** **Miscellaneous**
  
 +  * [[#do_you_have_a_user_forum|Do you have a user forum?]]
 +  * [[#how_does_zerene_stacker_work_with_lightroom|How does Zerene Stacker work with Lightroom?]]
 +  * [[##are_there_any_keyboard_shortcuts|Are there any keyboard shortcuts?]]
   * [[#is_there_some_way_to_turn_off_the_welcome_screen|Is there some way to turn off the welcome screen?]]   * [[#is_there_some_way_to_turn_off_the_welcome_screen|Is there some way to turn off the welcome screen?]]
   * [[#is_there_some_way_to_control_those_output_names|Is there some way to control those output names?]]   * [[#is_there_some_way_to_control_those_output_names|Is there some way to control those output names?]]
Line 52: Line 71:
   * [[#i_need_to_report_a_problem_are_there_log_files_i_can_send_you|I need to report a problem. Are there log files I can send you?]]   * [[#i_need_to_report_a_problem_are_there_log_files_i_can_send_you|I need to report a problem. Are there log files I can send you?]]
  
-===== What are the differences between Personal and Professional? =====+<html><a name="what_are_the_differences_between_personal_and_professional"</a></html> 
 +===== What are the differences between Personal, Prosumer, and Professional? =====
  
-Most of the differences are in the licensing termswhich require Professional Edition for uses beyond personal satisfaction.+There are two classes of differences: \\ 
 +1. how you are permitted to use the productand\\ 
 +2. what technical features are provided.
  
-In additionin the current release Professional Edition includes several advanced functions, as follows:+Very briefly**Professional Edition** is required for uses beyond personal satisfaction and educational instruction.  If you're selling images or using the software as part of your job or to support a business, museum, or funded project, then you need Professional Edition.  Professional Edition also provides access to the software's most advanced technical features and extended access to our support staff.
  
 +**Prosumer Edition** is our flagship product for non-professional users.  It includes all the technical features from Professional Edition, but at a reduced price for advanced consumers.
 +
 +Here is a full list of the features that require Prosumer Edition or Professional Edition.  (We call these features **"Pro-only"** for short.)
 +
 +  * Lightroom plugin
 +  * Option to honor image files' embedded color profiles in Zerene Stacker's own screen displays.
 +  * Ability to overlap I/O with computation for faster operation while stacking.
 +  * Ability to reduce the frequency of screen updates while stacking, for faster operation with deep stacks.
 +  * Additional brush types for retouching.
 +  * Multi-step undo when retouching.
 +  * Additional interpolators for improved handling of very sharp source images.
   * Integrated controller for the [[http://www.cognisys-inc.com/stackshot/stackshot.php|StackShot automated rail]]    * Integrated controller for the [[http://www.cognisys-inc.com/stackshot/stackshot.php|StackShot automated rail]] 
   * Ability to ingest and stack images while they are being shot with a USB-connected camera.   * Ability to ingest and stack images while they are being shot with a USB-connected camera.
Line 65: Line 98:
   * Depth map from DMap can be saved as a TIFF file.   * Depth map from DMap can be saved as a TIFF file.
  
-These features provide increased throughput and convenience; they do not affect output image quality.   +**Personal Edition** is our entry-level product.  It contains all the features that you're likely to need for most applications, plus free trials of the Pro-only features.  Trials of Pro-only features cover a 30-day period that starts when each feature is first used.  To continue using a Pro-only feature after its trial period has expiredyou can upgrade to Prosumer Edition by contacting [[support@zerenesystems.com]] .
- +
-As major new features are added, they will generally be available only in Professional (after a free trial period in Personal, of course).  If you're eligible for Personal Edition and you don't need the Professional-only features, then we recommend to buy Personal now and upgrade later if desired.+
  
 <html><a name="i_see_some_menu_items_labeled_pro_what_does_that_mean"</a></html> <html><a name="i_see_some_menu_items_labeled_pro_what_does_that_mean"</a></html>
 ===== I see some menu items labeled (Pro).  What does that mean? ===== ===== I see some menu items labeled (Pro).  What does that mean? =====
  
-Menu items are labeled (Pro) if you need a Professional Edition license to use them beyond a 30-day trial.  Each of these Pro features has a separate trial period that begins when that feature is used for the first time.  After first use, you can keep using the feature for another 30 calendar days.  If you don't have a Professional Edition license when the trial period expires, the feature becomes disabled and appears gray in the menu.  If you get tired of looking at those grayed-out items, go to Options > Preferences > Look & Feel, and select the option to "Hide unlicensed features after trial period has expired".+Menu items are labeled (Pro) if you need a Professional Edition or Prosumer Edition license to use them beyond a 30-day trial.  Each of these **"Pro-only"** features has a separate trial period that begins when that feature is used for the first time.  After first use, you can keep using the feature for another 30 calendar days.  If you don't have a Professional or Prosumer license when the trial period expires, the feature becomes disabled and appears gray in the menu.  If you get tired of looking at those grayed-out items, go to Options > Preferences > Look & Feel, and select the option to "Hide unlicensed features after trial period has expired"
 + 
 +===== Are program updates free? ===== 
 + 
 +Yes, updates are free. We've been issuing free updates ever since Zerene Stacker was first sold, back in 2009.  We have no plans to change that policy. It's so much simpler and more pleasant when everybody can just use the same current version
  
 ===== Do I have to pay more to get 64-bit mode? ===== ===== Do I have to pay more to get 64-bit mode? =====
Line 89: Line 124:
  
 The software is only available by download, but it's easy to make your own CD.  Each download is just a single file that is also suitable for offline installation.  Just use any machine that is connected to the Internet to download the version you need.  Burn it to CD or thumbdrive on that machine, then carry the CD or thumbdrive to your offline machine and install the software there.  Your license key can be transferred the same way.  Just write the email to a text file, burn that to CD or thumbdrive, move it to the offline machine, and install the key. The software is only available by download, but it's easy to make your own CD.  Each download is just a single file that is also suitable for offline installation.  Just use any machine that is connected to the Internet to download the version you need.  Burn it to CD or thumbdrive on that machine, then carry the CD or thumbdrive to your offline machine and install the software there.  Your license key can be transferred the same way.  Just write the email to a text file, burn that to CD or thumbdrive, move it to the offline machine, and install the key.
 +
 +===== How do I download and install the program? =====
 +
 +The latest regular release of Zerene Stacker is always posted on our [[http://zerenesystems.com/cms/stacker/softwaredownloads|Downloads]] page.  There is one separate file for each type of computer.  Choose the appropriate one and download it.  For Windows, the downloaded file is a classic Windows installer.  Just run it, and it will walk you through the installation process.  For Macintosh and Linux, the downloaded file is a self-contained bundle that does not need to be "installed".  Just put it anywhere you like, typically either on your Desktop or in your Applications folder.
 +
 +The first time you run Zerene Stacker, it will go through a short process of configuring memory allocation based on what type of computer you have and how much physical memory it has installed.  After this is done, the program will automatically restart and then you'll be ready to process images.
 +
 +===== I bought a license, how do I install it? =====
 +
 +Licenses get installed using copy/paste at Options > Registration while Zerene Stacker is running.  Just be sure to include the whole license key including all the equal signs ==== and everything between them.  For detailed instructions, see **[[:stacker:docs:howtoinstallalicensekey|HERE]]**.  If you're currently running an expired trial, then pay particular attention to step 5 because a browser window may be covering up part of Zerene Stacker that you need to install the license.
 +
 +===== How can I update the program? =====
 +
 +Program updates are posted as new installers, on the regular [[http://zerenesystems.com/cms/stacker/softwaredownloads|Downloads]] and [[http://zerenesystems.com/cms/stacker/softwaredownloads/currentbeta|Beta Downloads]] pages.
 +
 +Just visit one of those pages and download the appropriate version for your type of computer.
 +
 +Then install the download as if you were installing the program for the first time.
 +
 +On Windows, installing the new version will automatically replace the old version.
 +
 +On Macintosh and Linux, you will have to manually move the old version to trash, and move or rename the new version to replace it.  Otherwise both versions will continue to be available, and you will run whichever one you happen to click on.
 +
 +===== Can I have multiple versions installed at the same time? =====
 +
 +Yes, this works fine.  On Windows, just tell the installer to put the second version in a program folder and Start Menu folder that are different from the first version.  On Mac and Linux, the versions are simply distinguished by name and location, which you must specify manually.
 +
 +There is no limit to the number of versions that you can have installed simultaneously.  Each version is self contained and will operate independently except that they share a single folder that contains your license key, program configuration (Options > Preferences settings), and log files.
 +
 +===== Do you have a "beta test" channel? =====
 +
 +Yes, our beta test channel provides early notification and access to new features as they are developed.  The way it works is simple.  The latest public beta version is always posted on our [[http://zerenesystems.com/cms/stacker/softwaredownloads/currentbeta|Beta Testing Downloads]] page.  Versions that are downloaded from there have build numbers that end in "_beta".  Whenever you're running such a version, you will receive notifications of new updates and announcements for the beta channel, instead of the regular release channel.  You can move back and forth between beta and regular release channels whenever you want, just by downloading and installing the appropriate version of Zerene Stacker.
 +
 +===== Will Zerene Stacker work with my camera? =====
 +
 +Yes.  Zerene Stacker will work with any camera.  That's because it does not attempt to talk directly with your camera.  It just processes the image files that the camera creates.  You can tether your camera to a computer so that Zerene Stacker can immediately access the captured images, but in that case it will be some other piece of software that's talking with the camera.  Our **[[:stacker:docs:tutorials:tutorialsindex|Tutorials]]** section includes discussion of several commonly used software packages for tethering.
  
 ===== What kinds of image files will Zerene Stacker handle? ===== ===== What kinds of image files will Zerene Stacker handle? =====
  
-The input and output formats are JPEG and TIFF, the latter in either +The input and output formats are JPEG and TIFF, the latter in either 8- or 16-bit RGB.  In general the most reliable TIFF format is uncompressed; 
-8- or 16-bit RGB.  A few other formats such as PNG and BMP can be read but not written.+some compressed formats such as 16-bit ZIP are not readable.  A few other formats such as PNG and BMP can be read but not written.
  
 ===== Does Zerene Stacker handle raw files? ===== ===== Does Zerene Stacker handle raw files? =====
Line 112: Line 183:
 software provided by your camera manufacturer. software provided by your camera manufacturer.
  
 +If you use Lightroom, then be aware that there's a Lightroom plugin for Zerene Stacker
 +that handles raw conversion automatically.  When using Lightroom with the plugin, processing
 +raw files is just a matter of selecting them and doing an Export to Zerene Stacker.
 +See **[[stacker:docs:workingwithlightroom|Working with Lightroom]]** for more details
 +about this **[[:stacker:docs:faqlist#what_are_the_differences_between_personal_and_professional|"Pro-only"]]** feature.
 ===== How does Zerene Stacker handle color profiles? ===== ===== How does Zerene Stacker handle color profiles? =====
  
-By default, whatever color profile is used by the input files is also copied through to output files that are saved as JPEG or TIFF.  However, color profile is always ignored in Zerene Stacker's own screen displays.  As a result, stacks using a wide-gamut profile such as ProPhotoRGB may appear significantly different when displayed by Zerene Stacker than when displayed by Photoshop or similar tool.  On some computers Zerene Stacker will also ignore the color profile of your monitor, so that even sRGB images look different than shown in Photoshop.  These differences may be worrisome if you don't know what's causing them, but the key thing to remember is that the color profile will be correct in the output file.+By default, whatever color profile is used by the input files is also copied through to output files that are saved as JPEG or TIFF.  However, color profile is ignored in Zerene Stacker's own screen displays unless the option is set to "Use input file profiles for ZS screen displays" (at Options > Preferences > Color Management).  This advanced Pro-only feature is set off by default in the trial version.  As a result, stacks using a wide-gamut profile such as ProPhotoRGB may appear significantly different when displayed by Zerene Stacker than when displayed by Photoshop or similar tool.  On some computers Zerene Stacker will also ignore the color profile of your monitor, so that even sRGB images look different than shown in Photoshop.  These differences may be worrisome if you don't know what's causing them, but the key thing to remember is that the color profile will be correct in the output file.
  
 Note: there is an optional setting at Options > Preferences > Color Management that can cause color profiles to be omitted from output files.  If you're having trouble with profiles, check there to be sure that the Output option is selected to "Copy profile from input". Note: there is an optional setting at Options > Preferences > Color Management that can cause color profiles to be omitted from output files.  If you're having trouble with profiles, check there to be sure that the Output option is selected to "Copy profile from input".
Line 122: Line 198:
 You need to use File > Save Output Images(s).  That will give you a choice of TIFF or JPEG, with options appropriate for each format (compression quality for JPEG, 8- versus 16-bit for TIFF).   You need to use File > Save Output Images(s).  That will give you a choice of TIFF or JPEG, with options appropriate for each format (compression quality for JPEG, 8- versus 16-bit for TIFF).  
  
-It's a common mistake to use File > Save Project and then notice that what gets saved are .zsj and .zsy files that can't be used by anything besides Zerene Stacker.  File > Save Project is for tasks like coming back tomorrow to retouch an image that you generated today.  It stores images in lossless formats and keeps track of alignment information so that you can resume work immediately, with no expensive computation.+It's a common mistake to use File > Save Project and then notice that what gets saved are .zsj and .zsy files that can't be used by anything besides Zerene Stacker.  File > Save Project is for tasks like coming back tomorrow to retouch an image that you generated today.  It stores images in lossless formats and keeps track of alignment information so that you can resume work immediately, with no expensive computation.  See [[http://zerenesystems.com/cms/stacker/docs/howtouseit#saving_work_in_a_project|Saving Work In A "Project"]] for more discussion about that.
  
 ===== Why do my output images say they're only 72 dpi? ===== ===== Why do my output images say they're only 72 dpi? =====
  
 First, be reassured that your output images have the same number of pixels as your input images.  You haven't lost anything and all your original lovely detail is still there.  The output images themselves don't actually say 72 dpi.  What's happening is that Zerene Stacker has produced an output image that doesn't have a dpi specification at all, and whatever tool you're using to look at the image has assigned its own default interpretation of "72 dpi".  Dpi is not meaningful for screen images, and for prints dpi is implied by the combination of print size and pixel count.  If you really do need some particular setting for dpi inside the image file because that's how a requirement happens to be specified, then just pull the file into Photoshop, do an Image > Image Size... with the checkmark removed on "Resample Image", then save the result to a new file. First, be reassured that your output images have the same number of pixels as your input images.  You haven't lost anything and all your original lovely detail is still there.  The output images themselves don't actually say 72 dpi.  What's happening is that Zerene Stacker has produced an output image that doesn't have a dpi specification at all, and whatever tool you're using to look at the image has assigned its own default interpretation of "72 dpi".  Dpi is not meaningful for screen images, and for prints dpi is implied by the combination of print size and pixel count.  If you really do need some particular setting for dpi inside the image file because that's how a requirement happens to be specified, then just pull the file into Photoshop, do an Image > Image Size... with the checkmark removed on "Resample Image", then save the result to a new file.
 +
 +===== Does Zerene Stacker help me to shoot a stack? =====
 +
 +In most cases, no.  Typically you'll shoot a stack either by controlling focus manually, or by using a camera control device such as [[http://camranger.com/macro-focusstacking/|CamRanger]], or by tethering your camera and using a program like [[http://controlmynikon.com|ControlMyNikon]] or [[http://controlmycanon.com|ControlMyCanon]].  In all those cases, Zerene Stacker does not participate in the capture process.  The only time that Zerene Stacker gets involved in controlling the shooting of a stack is when you're using a [[http://www.cognisys-inc.com/stackshot/stackshot.php|StackShot rail]] and you've chosen to use Zerene Stacker's own Stackshot control panel for that.
  
 ===== Does Zerene Stacker correct for changes in magnification as I focus? ===== ===== Does Zerene Stacker correct for changes in magnification as I focus? =====
Line 134: Line 214:
 ===== Does it matter if I shoot the stack in order? ===== ===== Does it matter if I shoot the stack in order? =====
  
-For DMap, it's definitely best if the frames are processed in order, either front to back or back to front. If they're out of order, then the result may still look OK at first glance but it's almost certainly degraded.  Often there will be obvious artifacts like nasty halos.+For DMap, it's definitely best if the frames are processed in order, either front-to-back or back-to-front. If they're out of order, then the result may still look OK at first glance but it's almost certainly degraded.  Often there will be obvious artifacts like nasty halos.
  
 PMax itself does not care about order, but going from one end straight to the other is still the safe way to get good alignment. Sometimes when source frames are processed out of order, enough error accumulates in the alignment process that two frames focused at nearly the same depth but far apart in the stack order end up aligned slightly differently. When that happens, you get artifacts like "echoes".  PMax itself does not care about order, but going from one end straight to the other is still the safe way to get good alignment. Sometimes when source frames are processed out of order, enough error accumulates in the alignment process that two frames focused at nearly the same depth but far apart in the stack order end up aligned slightly differently. When that happens, you get artifacts like "echoes". 
 +
 +===== Does it matter if I work front-to-back or back-to-front? =====
 +
 +Front-to-back versus back-to-front makes no difference in most cases.  The visibility methods currently used by Zerene Stacker are symmetric with respect to depth order.  They produce the same image quality and artifacts no matter which way the stack is processed.  The default behavior is to start processing at the narrow end of the stack, meaning whichever end appears to have a smaller FOV based on comparing first and last frames. That choice reduces or eliminates edge streaking and in some cases can slightly improve the quality of alignment.  Options are provided to process the stack in a specific order if desired, but those are to control framing, not image quality. 
 +
 +One exception occurs if your subject is liable to move away while you're shooting.  In that case you should start at whichever end you consider most important, so that if the subject does leave you may still have something useful to work with.
 +===== Do I need a focus rail? =====
 +
 +If you're shooting very small subjects such as details of insects and flowers, then a high precision screw-driven focus rail is very helpful and sometimes required. 
 +
 +However, you don't need a focus rail for many applications, and in fact for larger subjects you'll probably get better results by stepping focus with the ring on your lens.  See [[:stacker:docs:troubleshooting:ringversusrail|HERE]] for more discussion on that point.  
 +
 +Lenses with auto-focus capability can usually be controlled very precisely by software if you tether your camera to a computer.  See the [[:stacker:docs:tutorials:tutorialsindex|Tutorials Index]] for suggestions regarding software to do that.
 +
 +===== How do I figure out what aperture setting and step size to use? =====
 +
 +There are several good ways to figure out what aperture setting and step size to use.  
 +
 +If you're going to be shooting a lot of stacks under similar conditions, then one very good method has four major steps:
 +  - Decide what magnification you want to shoot at.  Even with the same lens, the best aperture setting will be different at 1:1 than it is for a landscape.
 +  - At the selected magnification, shoot a series of pictures that vary the aperture setting over its entire range.  Look closely at the pictures and find the one that has the most depth of field while still retaining the sharpness you need, in the plane of best focus.  Whatever aperture setting took that picture, that's the one you want.
 +  - At the selected magnification and aperture setting, experiment with different step sizes to find the largest step size that gives a clean result with no focus banding.
 +  - Write down what you found, and use your notes to guide further work under similar circumstances.
 +The above procedure is very reliable and automatically incorporates your own criteria and the requirements of your own application.  Both of those can make large differences in determining which aperture setting and step size are best for what you're doing.  However, this experimental method obviously takes a fair amount of effort.
 +
 +As a shortcut, you can skip steps 3 and 4, and rely instead on the tables that we've provided **[[stacker:docs:tables:macromicrodof|HERE]]**.  They basically rely on computation to determine for you a step size that will prevent focus banding, once you have determined the magnification and aperture setting that you want to work at.  Similar tables that provide focus distances for landscape and other large scale work can be found **[[stacker:docs:tables:landscapes|HERE]]**.
 +
 +By the way, it turns out that the classic tables and formulas for DOF are not so good for focus stacking with modern cameras and display software.  They worked OK for shooting single pictures with film and prints, but now the numbers that they produce are often too large.  If you rely on the old values, you're very likely to see focus banding when you zoom in to look at "actual pixels" and full camera resolution.
  
 ===== How much memory should I allocate to Zerene Stacker? ===== ===== How much memory should I allocate to Zerene Stacker? =====
Line 162: Line 270:
 ===== My colors changed a little.  Why is that? ===== ===== My colors changed a little.  Why is that? =====
  
-There are two reasons that output images can have different colors from the input: brightness adjustment and PMax.  "Brightness adjustment" refers to Zerene Stacker's attempt to correct for uneven exposure between various input images.  That feature is turned on by default, but you can turn it off by un-checking Brightness at Options > Preferences > Alignment.  "PMax" refers to the PMax stacking method, which often makes slight changes in brightness, contrast, and saturation as a side effect of doing its focus stacking.  This behavior is an unavoidable side effect of PMax and should be considered as one of the tradeoffs of PMax versus DMap.  Color/brightness/contrast changes can be completely avoided by using the DMap stacking method, with Brightness adjustment turned off at Options > Preferences > Alignment.+There are three reasons that output images can have different colors from the input: 1) brightness adjustment, 2) PMax, and 3) "Retain full dynamic range" when saving.  "Brightness adjustment" refers to Zerene Stacker's attempt to correct for uneven exposure between various input images.  That feature is turned on by default, but you can turn it off by un-checking Brightness at Options > Preferences > Alignment.  "PMax" refers to the PMax stacking method, which often makes slight changes in brightness, contrast, and saturation as a side effect of doing its focus stacking.  This behavior is an unavoidable side effect of PMax and should be considered as one of the tradeoffs of PMax versus DMap.  "Retain full dynamic" when saving causes the range of internal pixel values to be compressed if necessary to fit within the 0-255 range of image files.  Internally the range can exceed 0-255 as a result of PMax, brightness adjustment, or even just pixel interpolation during alignment. 
 + 
 +Color/brightness/contrast changes can be completely avoided by using the DMap stacking method, with Brightness adjustment turned off at Options > Preferences > Alignment, and "Retain full dynamic range" turned off at Options > Preferences > Image Saving or in the file save dialog.
  
 ===== How should I set the Alignment options? ===== ===== How should I set the Alignment options? =====
Line 184: Line 294:
 ===== What is the difference between PMax and DMap? ===== ===== What is the difference between PMax and DMap? =====
  
-PMax is a “pyramid” method. It is very good at finding and preserving detail even in low contrast or slightly blurred areas. It's also very good at handling overlapping structures like mats of hair and crisscrossing bristles, nicely avoiding the loss-of-detail halos typical of other stacking programs. But PMax tends to increase noise and contrast, and it can alter colors somewhat.+PMax is a “pyramid” method. It is very good at finding and preserving detail even in low contrast or slightly blurred areas. It's also very good at handling overlapping structures like mats of hair and crisscrossing bristles, nicely avoiding the loss-of-detail halos typical of other stacking programs. But PMax tends to increase noise and contrast, it can alter colors somewhat, and it's liable to produce fuzzy "inversion halos" around strongly contrasting objects.
  
 DMap is a “depth map” method. It does a better job keeping the original smoothness and colors, but it's not as good at finding and preserving detail. DMap is a “depth map” method. It does a better job keeping the original smoothness and colors, but it's not as good at finding and preserving detail.
Line 194: Line 304:
 ===== How should I choose those DMap Settings? ===== ===== How should I choose those DMap Settings? =====
  
-As a guideline, the best values for the "radius" parameters at Options > Preferences > DMap Settings depend on two things: +First, note that there's tutorial specifically on "How To Use DMap".  Visit the __[[:stacker:docs:tutorials:tutorialsindex|Tutorials index page]]__ to find that. 
 + 
 +But as a quick guideline, the best values for the "radius" parameters at Options > Preferences > DMap Settings depend on two things: 
   - how sharp your images are,     - how sharp your images are,  
   - whether there's any side-to-side movement of the subject after alignment is done.     - whether there's any side-to-side movement of the subject after alignment is done.  
Line 201: Line 313:
  
   * If there's no movement and your images are sharp when viewed at 100% scale (actual pixels), then set Estimation Radius = 5.   * If there's no movement and your images are sharp when viewed at 100% scale (actual pixels), then set Estimation Radius = 5.
-  * If there's no movement but your images are blurred when viewed at 100% scale, then reduce the scale until the image does look sharp, and set Estimation Radius to 5 increased in proportion to the scale factor.  For example if your images look sharp at 50%, then set Estimation Radius = 10 (because 10 times 50% is 5).+  * If there's no movement but your images are blurred when viewed at 100% scale, then reduce the scale until the image does look sharp, and set Estimation Radius to 5 increased in proportion to the scale factor.  For example if your images look sharp at 50% (that is, reduced by 2X), then set Estimation Radius = 10 (because times is 10).  Similarly if your images look sharp only at 33% (reduced by 3X), then set Estimation Radius = 15 (because 5*3=15); at 25% (4X), set ER = 20; at 20% (5X), set ER = 25; and so on (Math geeks: compute ER=5/scale, where scale=0.25 for 25% and so on.)
   * If your stack has subject movement, then try setting Estimation Radius to between 1/100 and 1/200 of your image width in pixels, for example around 20-40 if your images are 4K pixels wide.   * If your stack has subject movement, then try setting Estimation Radius to between 1/100 and 1/200 of your image width in pixels, for example around 20-40 if your images are 4K pixels wide.
  
Line 207: Line 319:
  
 When DMap pauses for you to Set Contrast Selection, move the slider until out-of-focus background goes black in the preview image, while your subject retains most of its natural colors.  What you're doing is using your human judgment to mark "can't tell" regions where you want the program to emphasize smoothness rather than getting misled by pixel noise that might look like detail but isn't. When DMap pauses for you to Set Contrast Selection, move the slider until out-of-focus background goes black in the preview image, while your subject retains most of its natural colors.  What you're doing is using your human judgment to mark "can't tell" regions where you want the program to emphasize smoothness rather than getting misled by pixel noise that might look like detail but isn't.
 +
 +**Note:** If DMap does not pause for you to Set Contrast Selection, then go to Options > Preferences > DMap settings and remove the checkmark on "Use preset contrast threshold".  The software is distributed with that option not checked, but sometimes it gets checked by accident and then the lack of pause can be very confusing!
 +
 +===== Should I sharpen before or after running Zerene Stacker? =====
 +
 +In many cases it doesn't matter.  If you have a "smart" sharpening tool that can identify and sharpen real detail while leaving pixel noise largely unchanged, then you may get better results by running it before Zerene Stacker.  That's because it improves the "signal-to-noise ratio", which helps Zerene Stacker to make better decisions.  But with sharpening filters that do not have that level of discrimination, you'll get similar results either way and it's quicker and safer to just sharpen the final result.  If you do sharpen before stacking, be sure not to __over__sharpen because fixing that problem would require reprocessing the whole stack.
  
 ===== How can I detect movement in my stack? ===== ===== How can I detect movement in my stack? =====
Line 215: Line 333:
  
 By default, processing the stack also generates a set of highly compressed preview-quality images that can be played more quickly than the original high quality source images.  For this reason, it's usually better to put off "playing" your stack until after it's been processed once, unless you have some reason up front to suspect that subject movement may be an issue. By default, processing the stack also generates a set of highly compressed preview-quality images that can be played more quickly than the original high quality source images.  For this reason, it's usually better to put off "playing" your stack until after it's been processed once, unless you have some reason up front to suspect that subject movement may be an issue.
 +
 +===== Why did the software reverse the order of my images? =====
 +
 +Normally Zerene Stacker starts processing at whichever end of the stack has the narrower field of view.  This is to minimize or prevent edge streaking, which otherwise may appear in edge regions that are not covered by some source image.  The narrow end of the stack can be either foreground or background, depending on exactly what lens you're using and how you're doing the focus stepping.  The software determines which end is narrower by comparing images in the first and last frames.  Sometimes in microscopy the decision looks essentially random because it depends on the arrangement of objects in the image and how they appear to change size as they go into and out of focus.
 +
 +You can stop Zerene from automatically setting the order by going to Options > Preferences > Alignment and removing the checkmark on "Automatic order".  Then you can switch the order, if desired, by using File > "Reverse order".  
  
 ===== Can I directly control the order that images are processed? ===== ===== Can I directly control the order that images are processed? =====
  
-Sure.  First, go to Options > Preferences > Alignment and remove the checkmark on "Automatic order". This will prevent Zerene Stacker from rearranging the stack based on its analysis of field-of-view and image scale.  (By default, ZS processes the stack in order by file name, starting at whichever end has the narrowest field of view.)+Sure.  First, go to Options > Preferences > Alignment and remove the checkmark on "Automatic order". This will prevent Zerene Stacker from rearranging the stack based on its analysis of which end has a narrower field of view.
  
 If you need to set the order very precisely, then you may also have to add the images one at a time or in small groups, using drag-and-drop or Add File(s) multiple times. Each time you drop files into the Input Files panel or click the Add button inside the Add File(s) dialog, ZS will sort the newly added files by name. If you need to set the order very precisely, then you may also have to add the images one at a time or in small groups, using drag-and-drop or Add File(s) multiple times. Each time you drop files into the Input Files panel or click the Add button inside the Add File(s) dialog, ZS will sort the newly added files by name.
Line 234: Line 358:
 ===== What is the PMax setting "Retain UDR Image"? ===== ===== What is the PMax setting "Retain UDR Image"? =====
  
-UDR stands for Unrestricted Dynamic Range.  As discussed in the previous FAQ, the PMax stacking method often causes contrast to increase, pushing darks darker and brights brighter.  To compensate for this effect, the last step of the PMax method is a type of HDR (High Dynamic Range) local adjustment of contrast & brightness that preserves detail in overly light or dark regions while pushing those regions back into standard bounds.  By selecting the option to "Retain UDR Image", you can preserve the image as it stood just before the HDR step.  This allows you to run your own HDR methods outside Zerene Stacker, say in Photoshop.  When you select "Retain UDR Image", each run of PMax produces two Output Images, one of them with "UDR" in its name.  To finish processing that image outside Zerene Stacker, you should save it as 16-bit TIFF using "Retain full dynamic range" on the save.+UDR stands for Unrestricted Dynamic Range.  As discussed in the previous FAQ, the PMax stacking method often causes contrast to increase, pushing darks darker and brights brighter.  To compensate for this effect, the last step of the PMax method is a type of HDR (High Dynamic Range) local adjustment of contrast & brightness that preserves detail in overly light regions while pushing those regions back into standard bounds.  By selecting the option to "Retain UDR Image", you can preserve the image as it stood just before the HDR step.  This allows you to run your own HDR methods outside Zerene Stacker, say in Photoshop.  When you select "Retain UDR Image", each run of PMax produces two Output Images, one of them with "UDR" in its name.  To finish processing that image outside Zerene Stacker, you should save it as 16-bit TIFF using "Retain full dynamic range" on the save.
  
 ===== What are some tips for fast retouching? ===== ===== What are some tips for fast retouching? =====
  
 We have a whole separate page about that; see [[Tips for Retouching]]. We have a whole separate page about that; see [[Tips for Retouching]].
 +
 +===== Do you have a user forum? =====
 +
 +There is no forum dedicated to just Zerene Stacker. Instead, for most users we recommend going to [[http://www.photomacrography.net|photomacrography.net]], a strictly non-commercial web forum that covers all aspects of the photography of small things. Many of our users and the principal developer of Zerene Stacker are active participants there, and we prefer to keep our efforts concentrated in one place. Photomacrography.net has a well-earned reputation for in-depth technical information, combined with astounding images created by world-class photographers who are happy to discuss tips, techniques, and tools from all sources.  On the other hand, if you're working entirely with subjects that too large to discuss at photomacrography.net, then the best source of information is to email [[support@zerenesystems.com]].  We'll be happy to either answer your questions ourselves or point you to other resources as appropriate.
 +
 +===== How does Zerene Stacker work with Lightroom? =====
 +
 +We have a separate document for that: see [[:stacker:docs:workingwithlightroom|Working With Lightroom]].
 +
 +===== Are there any keyboard shortcuts? =====
 +
 +There are several keyboard and mouse shortcuts for selecting images and for adjusting image scale and brush size.  Those are described 
 +[[:stacker:docs:keyboardshortcuts|HERE]].  
 +
 +Currently there are no keyboard shortcuts for common operations such as opening and saving files.
  
 ===== Is there some way to turn off the welcome screen? ===== ===== Is there some way to turn off the welcome screen? =====
  
-On Macintosh no; on Windows, yes.  Right-click the launch icon to open Properties and go to the Shortcut tab.  Add the parameter -noSplashScreen to the end of the Target line, like this: +Yes.  Just go to Options > Preferences > Look & Feel, scroll down until you can see the option to "Suppress splash screen on launch", put a checkmark on that option, and exit from Zerene Stacker.  Your next launch should be quiet.
-      "C:\Program Files\ZereneStacker\zerenstk.exe-noSplashScreen+
              
 ===== Is there some way to control those output names? ===== ===== Is there some way to control those output names? =====
  
-You've probably noticed that the default names are based on timestamps --- good for uniqueness but not necessarily what you want for readability.  You can construct your own templates to include source image numbers, processing options, and so on.  Go to [[:stacker:docs:options:preferences:imagesaving|Options > Preferences > Image Saving]] and look at the Template field. +You've probably noticed that the default names are based on timestamps --- good for uniqueness but not necessarily what you want for readability.  You can construct your own templates to include source image numbers, processing options, and so on.  This feature is documented at **[[:stacker:docs:options:preferences:imagesaving|Options > Preferences > Image Saving]]**; look at the Template field. 
  
 ===== The Zerene Stacker icon -- what is it? ===== ===== The Zerene Stacker icon -- what is it? =====
Line 259: Line 397:
 To locate log and configuration files, proceed as follows: To locate log and configuration files, proceed as follows:
   * On Windows, do a Start > Run on the Windows taskbar.  In the little window that pops up, specify to Open: "%APPDATA%\ZereneStacker" (note, no space in the name).  Click OK.  This will open a file explorer window showing the ZereneStacker folder in your user area. \\ \\    * On Windows, do a Start > Run on the Windows taskbar.  In the little window that pops up, specify to Open: "%APPDATA%\ZereneStacker" (note, no space in the name).  Click OK.  This will open a file explorer window showing the ZereneStacker folder in your user area. \\ \\ 
-  * On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory's Library/Preferences/ZereneStacker.  \\ Note that the required directory is //not// in the /Library/Preferences that hangs off the root of your disk.  Instead it is the one located in your home directory, **~**/Library/Preferences.  If in doubt, open a Finder window, go to DEVICES and open your root disk, then go to Users, then to your own username, then to Library, then to Preferences, then to ZereneStacker.  In the latest "Lion" version of Mac OS Xthe Library folder is normally hidden.  To see into it, use the simple method shown [[http://creativebits.org/mac_os_x/show_library_folder_os_x_107|HERE]].+  * On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory's Library/Preferences/ZereneStacker.  \\ Note that the required directory is //not// in the /Library/Preferences that hangs off the root of your computer's disk.  Instead it is the one located in your own home directory, **~**/Library/Preferences.  In recent versions of Mac OS X ("Lion" and later)your own Library folder is normally hidden in Finder.  To see into it, simply click the Go menu in Finder, then press and hold the Option (Alt) key to add Library to the list of available folders (as shown [[http://creativebits.org/mac_os_x/show_library_folder_os_x_107|HERE]]).  Continue holding the Option key while you click on Library to view its contents, then double-click to open the Preferences folder and then the ZereneStacker folder.
  
-Probably the ZereneStacker folder/directory will contain several log files.  To identify the proper one, consider the circumstances:  If you received a popup diagnostic that said "Uh-oh -- something went wrong and caused an internal error", then the file is named something like *ErrorLog20110508090456.txt, where the digits indicate date & time (2011 May 8 at 09:04:56 am).  If you did not receive such a popup, then the log file is LastNormalLog.txt. +Probably the ZereneStacker folder will contain several log files.  To identify the proper one, consider the circumstances:  If you received a popup diagnostic that said "Uh-oh -- something went wrong and caused an internal error", then the file is named something like *ErrorLog20110508090456.txt, where the digits indicate date & time (2011 May 8 at 09:04:56 am).  If you did not receive such a popup, then the log file is LastNormalLog.txt. 
stacker/docs/faqlist.1341900739.gz · Last modified: 2012/07/10 02:12
Copyright 2013, Zerene Systems LLC, all rights reserved.