Zerene Stacker

Differences

This shows you the differences between two versions of the page.

stacker:docs:faqlist [2018/05/29 01:20]
rjlittlefield
stacker:docs:faqlist [2019/05/15 01:03] (current)
rjlittlefield [How should I choose those DMap Settings?]
Line 7: Line 7:
   * [[#what_are_the_differences_between_personal_prosumer_and_professional|What are the differences between Personal, Prosumer, and Professional?]]   * [[#what_are_the_differences_between_personal_prosumer_and_professional|What are the differences between Personal, Prosumer, and Professional?]]
   * [[#i_see_some_menu_items_labeled_pro__what_does_that_mean|I see some menu items labeled (Pro). What does that mean?]]   * [[#i_see_some_menu_items_labeled_pro__what_does_that_mean|I see some menu items labeled (Pro). What does that mean?]]
 +  * [[#do_you_have_a_free_trial|Do you have a free trial?]]
   * [[#are_program_updates_free|Are program updates free?]]   * [[#are_program_updates_free|Are program updates free?]]
   * [[#do_i_have_to_pay_more_to_get_64-bit_mode|Do I have to pay more to get 64-bit mode?]]   * [[#do_i_have_to_pay_more_to_get_64-bit_mode|Do I have to pay more to get 64-bit mode?]]
Line 46: Line 47:
   * [[#what_is_the_best_way_to_add_files|What is the best way to add files?]]   * [[#what_is_the_best_way_to_add_files|What is the best way to add files?]]
   * [[#my_output_image_has_a_band_of_streaks_on_one_side_why_is_that|My output image has a band of streaks on one side.  Why is that?]]   * [[#my_output_image_has_a_band_of_streaks_on_one_side_why_is_that|My output image has a band of streaks on one side.  Why is that?]]
 +  * [[#my_output_images_have_worm_trails_why_is_that|My output images have worm trails!  Why is that?]]
   * [[#my_colors_changed_a_little_why_is_that|My colors changed a little.  Why is that?]]   * [[#my_colors_changed_a_little_why_is_that|My colors changed a little.  Why is that?]]
   * [[#why_do_my_images_look_noisy_as_soon_as_i_load_them_into_zerene_stacker|Why do my images look noisy as soon as I load them into Zerene Stacker?]]   * [[#why_do_my_images_look_noisy_as_soon_as_i_load_them_into_zerene_stacker|Why do my images look noisy as soon as I load them into Zerene Stacker?]]
Line 110: Line 112:
  
 <html><a name="i_see_some_menu_items_labeled_pro_what_does_that_mean"</a></html> <html><a name="i_see_some_menu_items_labeled_pro_what_does_that_mean"</a></html>
 +
 ===== I see some menu items labeled (Pro).  What does that mean? ===== ===== I see some menu items labeled (Pro).  What does that mean? =====
  
Line 115: Line 118:
  
 Please see [[stacker:docs:faqlist?&#what_are_the_differences_between_personal_prosumer_and_professional|"What are the differences between Personal, Prosumer, and Professional?"]] for a list of all the Pro-only features. Please see [[stacker:docs:faqlist?&#what_are_the_differences_between_personal_prosumer_and_professional|"What are the differences between Personal, Prosumer, and Professional?"]] for a list of all the Pro-only features.
 +
 +===== Do you have a free trial? =====
 +
 +Yes, there is a free 30-day trial. 
 +
 +The software downloads from [[https://zerenesystems.com/cms/stacker/softwaredownloads]] . 
 +
 +When first installed, it runs in free trial mode, which provides full functionality for 30 days from first execution.  After that, the software will still run but screen images are watermarked and saving images and projects is disabled.  At any time, installation of a purchased license key will unlock the software for permanent use.
 +
 +By default, the technical features in trial mode are identical to those that would continue to be provided by a Personal Edition license key.  Advanced features that require a Prosumer Edition or Professional Edition license key are also available, and provide a popup message letting you know that a Pro-only feature has been used.
 +
 ===== Are program updates free? ===== ===== Are program updates free? =====
  
Line 307: Line 321:
  
 Edge streaks can also be caused by forcing a stack to be processed starting at the "wide" end, meaning whichever end of the stack has the widest field of view.  In this case the streaks are likely to appear on all four edges, and may extend from the edge of the image to the edge of the narrowest field of view.  With standard settings, Zerene Stacker automatically determines which is the narrow end of the stack and starts there, which completely prevents edge streaks with a well aligned stack.  However, it can be forced to start at either end by de-selecting Options > Preferences > "Automatic order".  Normally we recommend to leave "Automatic order" selected, and set things up when the stack is shot so that everything you care about is contained even within the narrowest frame.  See the tutorial [[http://zerenesystems.com/cms/stacker/docs/tutorials/tutorial002#summaryuse_either_method_but_be_sure_to_check_framing|HERE]] for more information on that point. Edge streaks can also be caused by forcing a stack to be processed starting at the "wide" end, meaning whichever end of the stack has the widest field of view.  In this case the streaks are likely to appear on all four edges, and may extend from the edge of the image to the edge of the narrowest field of view.  With standard settings, Zerene Stacker automatically determines which is the narrow end of the stack and starts there, which completely prevents edge streaks with a well aligned stack.  However, it can be forced to start at either end by de-selecting Options > Preferences > "Automatic order".  Normally we recommend to leave "Automatic order" selected, and set things up when the stack is shot so that everything you care about is contained even within the narrowest frame.  See the tutorial [[http://zerenesystems.com/cms/stacker/docs/tutorials/tutorial002#summaryuse_either_method_but_be_sure_to_check_framing|HERE]] for more information on that point.
 +
 +===== My output images have worm trails!  Why is that? =====
 +
 +That description sounds like what we call "dust trails" or "hot pixel trails", depending on whether the trails are darker or lighter than their surroundings.
 +
 +If you carefully check your source images, you will find that in each of them there are a few individual spots, one spot for each trail in your output.
 +
 +Those spots will occur at exactly the same pixel coordinates in each source image.
 +
 +The reason that trails appear during the stacking process is this:  Due to magnification changes, jitter, or systematic drift in your focus stepping setup, the subject moves slightly left/right/up/down in each frame.  Essentially the subject is moving around with respect to the spots.  In order to make a clean rendering, the focus stacking process must correct for the subject movement, so the subject stays in the same place for each frame.  But then the spots appear to move around with respect to the subject.  To the focus stacking algorithms, the spots look just like sharp detail that should be retained, and so in the final image you see each spot in every position that it ever occupied with respect to the subject.  In combination with the human eye's great ability to pick out linear structures, this causes each spot to become a collection of spots that looks like a straight line, a wiggly trail, or something in between, depending on exactly how the jitter and drift behaved in the first place.
 +
 +In general, these sorts of artifacts can be called "defect trails", because they are trails of small defects in the original images.  The most common form is "dust trails" due to dust on the sensor, producing dark trails on light backgrounds.  Light spots, typically very small, are caused by "warm pixels", in which individual photosites on the camera sensor accumulate charge due to electrical leakage in addition to light exposure.
 +
 +The best cure for these problems is to prevent them in the first place.  Fixing the problem after the stack has been shot inevitably means guessing about what the pixel values should have been, that were hidden by the spots.  So, it's best to clean your sensor and keep it that way.  Warm pixels get worse with long exposures and higher temperatures, so the best way to avoid them is to use short exposures by adding light, typically flash.  It also helps to avoid Live View mode during actual shooting, if possible, because continuous use of the sensor during Live View causes the sensor to get warmer.
 +
 +If you cannot avoid dust or warm pixels in the first place, then the second-best approach is to remove them before stacking, using some technique equivalent to batch mode dust removal.  This can be done using tools such as Lightroom or Photoshop.  You can find a lot of information about this by searching the internet for words like "remove dust from multiple pictures".  Alternatively, it often works great to paint over the trails by retouching, either inside Zerene Stacker using Edit > Retouching, or outside Zerene Stacker using something like Photoshop's healing brush or clone tool.
 +
 ===== My colors changed a little.  Why is that? ===== ===== My colors changed a little.  Why is that? =====
  
-There are three reasons that output images can have different colors from the input: 1) brightness adjustment, 2) PMax, and 3) "Retain extended dynamic range" when saving.  "Brightness adjustment" refers to Zerene Stacker's attempt to correct for uneven exposure between various input images.  That feature is turned on by default, but you can turn it off by un-checking Brightness at Options > Preferences > Alignment.  "PMax" refers to the PMax stacking method, which often makes slight changes in brightness, contrast, and saturation as a side effect of doing its focus stacking.  This behavior is an unavoidable side effect of PMax and should be considered as one of the tradeoffs of PMax versus DMap.  "Retain extended dynamic range" when saving causes the range of internal pixel values to be compressed if necessary to fit within the 0-255 range of image files.  Internally the range can exceed 0-255 as a result of PMax, brightness adjustment, or even just pixel interpolation during alignment.+There are three common reasons that saved output images can have different colors from the input: 1) brightness adjustment, 2) PMax, and 3) "Retain extended dynamic range" when saving.  "Brightness adjustment" refers to Zerene Stacker's attempt to correct for uneven exposure between various input images.  That feature is turned on by default, but you can turn it off by un-checking Brightness at Options > Preferences > Alignment.  "PMax" refers to the PMax stacking method, which often makes slight changes in brightness, contrast, and saturation as a side effect of doing its focus stacking.  This behavior is an unavoidable side effect of PMax and should be considered as one of the tradeoffs of PMax versus DMap.  "Retain extended dynamic range" when saving causes the range of internal pixel values to be compressed if necessary to fit within the 0-255 range of image files.  Internally the range can exceed 0-255 as a result of PMax, brightness adjustment, or even just pixel interpolation during alignment.
  
-Color/brightness/contrast changes can be completely avoided by using the DMap stacking method, with Brightness adjustment turned off at Options > Preferences > Alignment, and "Retain extended dynamic range" turned off at Options > Preferences > Image Saving or in the file save dialog.+These sorts of color/brightness/contrast changes in the saved images can be completely avoided by using the DMap stacking method, with Brightness adjustment turned off at Options > Preferences > Alignment, and "Retain extended dynamic range" turned off at Options > Preferences > Image Saving or in the file save dialog.
  
 +In some unusual cases, color changes can also result from issues in the handling of color profiles of the image files and/or monitor.  See the discussion above, at [[https://zerenesystems.com/cms/stacker/docs/faqlist#how_does_zerene_stacker_handle_color_profiles|How does Zerene Stacker handle color profiles?]]
 ===== Why do my images look noisy as soon as I load them into Zerene Stacker? ===== ===== Why do my images look noisy as soon as I load them into Zerene Stacker? =====
  
Line 341: Line 373:
 ===== What is the difference between PMax and DMap? ===== ===== What is the difference between PMax and DMap? =====
  
-PMax is a “pyramid” method. It is very good at finding and preserving detail even in low contrast or slightly blurred areas. It's also very good at handling overlapping structures like mats of hair and crisscrossing bristles, nicely avoiding the loss-of-detail halos typical of other stacking programs. But PMax tends to increase noise and contrast, it can alter colors somewhat, and it's liable to produce fuzzy "inversion halos" around strongly contrasting objects.+PMax is a "pyramid" method. It is very good at finding and preserving detail even in low contrast or slightly blurred areas. It's also very good at handling overlapping structures like mats of hair and crisscrossing bristles, nicely avoiding the loss-of-detail halos typical of other stacking programs. But PMax tends to increase noise and contrast, it can alter colors somewhat, and it's liable to produce fuzzy "inversion halos" around strongly contrasting objects.
  
-DMap is a “depth map” method. It does a better job keeping the original smoothness and colors, but it's not as good at finding and preserving detail.+DMap is a "depth map" method. It does a better job keeping the original smoothness and colors, but it's not as good at finding and preserving detail.
  
 The two methods complement each other. Some types of subjects look good when they are processed automatically by PMax, but not by DMap. Other subjects are just the opposite. For particularly challenging subjects like bugs and flowers shot through microscope objectives, neither method is ideal by itself. In that case the best results are obtained by using human judgment and the retouching tool to combine the best aspects of both algorithms. The two methods complement each other. Some types of subjects look good when they are processed automatically by PMax, but not by DMap. Other subjects are just the opposite. For particularly challenging subjects like bugs and flowers shot through microscope objectives, neither method is ideal by itself. In that case the best results are obtained by using human judgment and the retouching tool to combine the best aspects of both algorithms.
Line 365: Line 397:
 In any case, set Smoothing Radius to half the value of Estimation Radius. In any case, set Smoothing Radius to half the value of Estimation Radius.
  
-When DMap pauses for you to Set Contrast Selection, move the slider until out-of-focus background goes black in the preview image, while your subject retains most of its natural colors.  What you're doing is using your human judgment to mark "can't tell" regions where you want the program to emphasize smoothness rather than getting misled by pixel noise that might look like detail but isn't.+When DMap pauses for you to Set Contrast Selection, you're supposed to move the slider until out-of-focus background goes black in the preview image, while your subject retains most of its natural colors.  What you're doing is using your human judgment to mark "can't tell" regions where you want the program to emphasize smoothness rather than getting misled by pixel noise that might look like detail but isn't
 + 
 +When you use the slider, you are actually setting two numbers: the //percentile// which says what fraction of pixels ended up getting shown as "black in preview" (that is, contrast of details is below threshold), and the //level// which describes the strength of detail at the break between "black in preview" and normal colors.  The numeric value of level is not meaningful to a human, beyond the understanding that the values will be larger in areas that show sharp detail with high contrast, and smaller in areas where there is less detail to be seen. 
 + 
 +Usually it is best to set the slider interactively on every stack.  However, for batch operations where you have a bunch of stacks with similar appearance, you can checkmark the option to "Use preset contrast threshold".  That prevents the slider and preview image from being shown, so that multiple DMap operations can be done with no user interaction.  In that case, you must also select to either use the value of Level that was left over from the last interactive setting of the slider, or compute a new threshold for each stack based on specified Percentile and the image contents of that stack. 
 + 
 +Suppose, for example, that you're doing product photography.  If your collection of stacks consists of various colors of shoes photographed against a uniform background, then it's probably best to select Percentile because the shoes may have very different appearances but all will cover about the same fraction of the frame.  But if you're photographing an assortment of diamond and silver jewelry, say rings, bracelets, and necklaces, then it would be best to select Level because different pieces of jewelry would cover much different fractions of the frame but have similar appearance of detail in whatever region they did cover.
  
 **Note:** If DMap does not pause for you to Set Contrast Selection, then go to Options > Preferences > DMap settings and remove the checkmark on "Use preset contrast threshold".  The software is distributed with that option not checked, but sometimes it gets checked by accident and then the lack of pause can be very confusing! **Note:** If DMap does not pause for you to Set Contrast Selection, then go to Options > Preferences > DMap settings and remove the checkmark on "Use preset contrast threshold".  The software is distributed with that option not checked, but sometimes it gets checked by accident and then the lack of pause can be very confusing!
Line 460: Line 498:
 [[:stacker:docs:keyboardshortcuts|HERE]].   [[:stacker:docs:keyboardshortcuts|HERE]].  
  
-Currently there are no keyboard shortcuts for common operations such as opening and saving files.+Recent versions of Zerene Stacker also have keyboard shortcuts for some common operations such as opening and saving files.  These are identified in the menu system, as usual for whatever type of computer you are using. 
  
 ===== Is there some way to turn off the welcome screen? ===== ===== Is there some way to turn off the welcome screen? =====
Line 468: Line 507:
 ===== Is there some way to control those output names? ===== ===== Is there some way to control those output names? =====
  
-You've probably noticed that the default names are based on timestamps --good for uniqueness but not necessarily what you want for readability.  You can construct your own templates to include source image numbers, processing options, and so on.  This feature is documented at **[[:stacker:docs:options:preferences:imagesaving|Options > Preferences > Image Saving]]**; look at the Template field. +You've probably noticed that the default names are based on timestamps, for example "2018-12-01_16.48.14" means 2018 December 01 at 4:48 PM plus 14 seconds (local time zone).  Names like that are good for uniqueness but not necessarily what you want for readability.  You can construct your own templates to include source image numbers, processing options, and so on.  This feature is documented at **[[:stacker:docs:options:preferences:imagesaving|Options > Preferences > Image Saving]]**; look at the Template field. 
  
 ===== How can I find and remove orphaned files? ===== ===== How can I find and remove orphaned files? =====
Line 489: Line 528:
  
 To locate log and configuration files, proceed as follows: To locate log and configuration files, proceed as follows:
-  * On Windows, do a Start > Run on the Windows taskbar.  In the little window that pops up, specify to Open: "%APPDATA%\ZereneStacker" (note, no space in the name).  Click OK.  This will open a file explorer window showing the ZereneStacker folder in your user area. \\ \\ On Windows 10, usually it is not possible to open the Start > Run dialog.  Instead, you can open a File Explorer window, then in that window's address bar, type in %APPDATA%\ZereneStacker and hit the Enter key. Searching Windows for %APPDATA%\ZereneStacker will also work.  \\ \\ On some systems, it is also necessary to set the folder view options to "Show hidden files, folders, and drives".  See for example [[http://www.windows10themes.net/guides/how-to-view-the-appdata-folder-in-windows-10/]] \\ \\ +  * On Windows, do a Start > Run on the Windows taskbar.  In the little window that pops up, specify to Open: "%APPDATA%\ZereneStacker" (omit the quotesand no space in the name).  Click OK.  This will open a file explorer window showing the ZereneStacker folder in your user area. \\ \\ On Windows 10, usually it is not possible to open the Start > Run dialog.  Instead, you can open a File Explorer window, then in that window's address bar, type in %APPDATA%\ZereneStacker and hit the Enter key. Searching Windows for %APPDATA%\ZereneStacker will also work.  \\ \\ On some systems, it is also necessary to set the folder view options to "Show hidden files, folders, and drives".  See for example [[http://www.windows10themes.net/guides/how-to-view-the-appdata-folder-in-windows-10/]] \\ \\ 
-  * On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory's Library/Preferences/ZereneStacker.  \\ Note that the required directory is //not// in the /Library/Preferences that hangs off the root of your computer's disk.  Instead it is the one located in your own home directory, **~**/Library/Preferences.  In recent versions of Mac OS X ("Lion" and later), your own Library folder is normally hidden in Finder.  To see into it, simply click the Go menu in Finder, then press and hold the Option (Alt) key to add Library to the list of available folders (as shown [[http://creativebits.org/mac_os_x/show_library_folder_os_x_107|HERE]]).  Continue holding the Option key while you click on Library to view its contents, then double-click to open the Preferences folder and then the ZereneStacker folder.+  * On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory's Library/Preferences/ZereneStacker.  \\ Note that the required directory is //not// in the /Library/Preferences that hangs off the root of your computer's disk.  Instead it is the one located in your own home directory, **~**/Library/Preferences.  In modern versions of Mac OS X ("Lion" and later), your own Library folder is normally hidden in Finder.  To see into it, simply click the Go menu in Finder, then press and hold the Option (Alt) key to add Library to the list of available folders (as shown [[http://osxdaily.com/2016/12/12/show-user-library-folder-macos-sierra/|HERE]]).  Continue holding the Option key while you click on Library to view its contents, then double-click to open the Preferences folder and then the ZereneStacker folder.
  
 Probably the ZereneStacker folder will contain several log files.  To identify the proper one, consider the circumstances:  If you received a popup diagnostic that said "Uh-oh -- something went wrong and caused an internal error", then the file is named something like ErrorLog<timestamp>.txt or AutoErrorLog<timestamp>.txt, where <timestamp> is a string of digits that indicate date & time.  For example the file may be named ErrorLog20110508090456.txt, for a problem that occurred on 2011 May 8 at 09:04:56 am.  If you did not receive such a popup, then the log file is LastNormalLog.txt.  Probably the ZereneStacker folder will contain several log files.  To identify the proper one, consider the circumstances:  If you received a popup diagnostic that said "Uh-oh -- something went wrong and caused an internal error", then the file is named something like ErrorLog<timestamp>.txt or AutoErrorLog<timestamp>.txt, where <timestamp> is a string of digits that indicate date & time.  For example the file may be named ErrorLog20110508090456.txt, for a problem that occurred on 2011 May 8 at 09:04:56 am.  If you did not receive such a popup, then the log file is LastNormalLog.txt. 
Line 504: Line 543:
 \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\
 \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\
-\\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\+\\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\
  
  
stacker/docs/faqlist.1527556844.gz · Last modified: 2018/05/29 01:20
Copyright 2009-2018, Zerene Systems LLC, all rights reserved.