Zerene Stacker

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
stacker:docs:faqlist [2019/10/03 00:00]
rjlittlefield [Why does the program complain that my images are different sizes?]
stacker:docs:faqlist [2020/06/29 19:07] (current)
rjlittlefield Part of my subject looks transparent. What can I do?
Line 5: Line 5:
 **Purchasing** **Purchasing**
  
 +  * [[#​do_you_have_a_free_trial|Do you have a free trial?]]
   * [[#​what_are_the_differences_between_personal_prosumer_and_professional|What are the differences between Personal, Prosumer, and Professional?​]]   * [[#​what_are_the_differences_between_personal_prosumer_and_professional|What are the differences between Personal, Prosumer, and Professional?​]]
   * [[#​i_see_some_menu_items_labeled_pro__what_does_that_mean|I see some menu items labeled (Pro). What does that mean?]]   * [[#​i_see_some_menu_items_labeled_pro__what_does_that_mean|I see some menu items labeled (Pro). What does that mean?]]
-  * [[#do_you_have_a_free_trial|Do you have a free trial?]]+  * [[#can_i_test_professional_and_prosumer_options_in_trial|Can I test Professional and Prosumer options in trial?]]
   * [[#​are_program_updates_free|Are program updates free?]]   * [[#​are_program_updates_free|Are program updates free?]]
   * [[#​do_i_have_to_pay_more_to_get_64-bit_mode|Do I have to pay more to get 64-bit mode?]]   * [[#​do_i_have_to_pay_more_to_get_64-bit_mode|Do I have to pay more to get 64-bit mode?]]
Line 50: Line 51:
   * [[#​my_colors_changed_a_little_why_is_that|My colors changed a little. ​ Why is that?]]   * [[#​my_colors_changed_a_little_why_is_that|My colors changed a little. ​ Why is that?]]
   * [[#​why_do_my_images_look_noisy_as_soon_as_i_load_them_into_zerene_stacker|Why do my images look noisy as soon as I load them into Zerene Stacker?]]   * [[#​why_do_my_images_look_noisy_as_soon_as_i_load_them_into_zerene_stacker|Why do my images look noisy as soon as I load them into Zerene Stacker?]]
 +  * [[#​part_of_my_subject_looks_transparent_what_can_i_do|Part of my subject looks transparent. What can I do?]]
   * [[#​how_should_i_set_the_alignment_options|How should I set the Alignment options?]]   * [[#​how_should_i_set_the_alignment_options|How should I set the Alignment options?]]
   * [[#​what_do_the_percentages_mean_for_alignment_parameters|What do the percentages mean for Alignment parameters?​]]   * [[#​what_do_the_percentages_mean_for_alignment_parameters|What do the percentages mean for Alignment parameters?​]]
   * [[#​what_is_the_difference_between_pmax_and_dmap|What is the difference between PMax and DMap?]]   * [[#​what_is_the_difference_between_pmax_and_dmap|What is the difference between PMax and DMap?]]
   * [[#​how_should_i_choose_those_dmap_settings|How should I choose those DMap Settings?]]   * [[#​how_should_i_choose_those_dmap_settings|How should I choose those DMap Settings?]]
 +  * [[#​what_is_slabbing|What is "​slabbing"?​]]
   * [[#​should_i_sharpen_before_or_after_running_zerene_stacker|Should I sharpen before or after running Zerene Stacker?]]   * [[#​should_i_sharpen_before_or_after_running_zerene_stacker|Should I sharpen before or after running Zerene Stacker?]]
   * [[#​how_can_i_detect_movement_in_my_stack|How can I detect movement in my stack?]]   * [[#​how_can_i_detect_movement_in_my_stack|How can I detect movement in my stack?]]
Line 64: Line 67:
   * [[#​are_there_settings_to_make_stacks_process_faster|Are there settings to make stacks process faster?]]   * [[#​are_there_settings_to_make_stacks_process_faster|Are there settings to make stacks process faster?]]
   * [[#​why_does_the_program_complain_that_my_images_are_different_sizes|Why does the program complain that my images are different sizes?]]   * [[#​why_does_the_program_complain_that_my_images_are_different_sizes|Why does the program complain that my images are different sizes?]]
 +  * [[#​_when_do_options_preferences_values_get_saved_and_reloaded|When do Options > Preferences values get saved and reloaded?]]
  
 **Retouching** **Retouching**
Line 80: Line 84:
   * [[#​the_zerene_stacker_icon_--_what_is_it|The Zerene Stacker icon -- what is it?]]   * [[#​the_zerene_stacker_icon_--_what_is_it|The Zerene Stacker icon -- what is it?]]
   * [[#​i_need_to_report_a_problem_are_there_log_files_i_can_send_you|I need to report a problem. Are there log files I can send you?]]   * [[#​i_need_to_report_a_problem_are_there_log_files_i_can_send_you|I need to report a problem. Are there log files I can send you?]]
 +
 +===== Do you have a free trial? =====
 +
 +Yes, there is a free 30-day trial. ​
 +
 +The software downloads from [[https://​zerenesystems.com/​cms/​stacker/​softwaredownloads]] . 
 +
 +When first installed, it runs in free trial mode, which provides full functionality for 30 days from first execution. ​ After that, the software will still run but screen images are watermarked and saving images and projects is disabled. ​ At any time, installation of a purchased license key will unlock the software for permanent use.
 +
 +By default, the technical features in trial mode are identical to those that would continue to be provided by a Personal Edition license key.  Advanced features that require a Prosumer Edition or Professional Edition license key are also available, and provide a popup message letting you know that a Pro-only feature has been used.
  
 <​html><​a name="​what_are_the_differences_between_personal_and_professional"</​a></​html>​ <​html><​a name="​what_are_the_differences_between_personal_and_professional"</​a></​html>​
Line 95: Line 109:
  
   * Preserve all metadata, including EXIF, IPTC, and any Lightroom keywords that have been added by the photographer.   * Preserve all metadata, including EXIF, IPTC, and any Lightroom keywords that have been added by the photographer.
-  * Lightroom plugin+  * Lightroom plugin
 +  * Use dust and hot pixels mask while stacking, to avoid defect trails. 
 +  * Built-in capability for "​slabbing"​.
   * Option to honor image files' embedded color profiles in Zerene Stacker'​s own screen displays.   * Option to honor image files' embedded color profiles in Zerene Stacker'​s own screen displays.
   * Ability to overlap I/O with computation for faster operation while stacking.   * Ability to overlap I/O with computation for faster operation while stacking.
Line 119: Line 135:
 Please see [[stacker:​docs:​faqlist?&#​what_are_the_differences_between_personal_prosumer_and_professional|"​What are the differences between Personal, Prosumer, and Professional?"​]] for a list of all the Pro-only features. Please see [[stacker:​docs:​faqlist?&#​what_are_the_differences_between_personal_prosumer_and_professional|"​What are the differences between Personal, Prosumer, and Professional?"​]] for a list of all the Pro-only features.
  
-===== Do you have a free trial? =====+===== Can I test Professional and Prosumer options in trial? =====
  
-Yes, there is a free 30-day trial. ​+Yes, all of the Professional and Prosumer options are available during the free 30-day trial.
  
-The software downloads from [[https://​zerenesystems.com/​cms/​stacker/​softwaredownloads]] ​+In trial, the program'​s default settings are the same as for Personal and Student Editions 
  
-When first installedit runs in free trial mode, which provides full functionality for 30 days from first execution. ​ After that, the software will still run but screen images are watermarked and saving images and projects is disabled. ​ At any time, installation of purchased ​license key will unlock ​the software for permanent use.+Soto see exactly how Prosumer or Professional Edition ​license key would behave, you'll need to check-mark ​the following settings explicitly:
  
-By default, the technical features in trial mode are identical ​to those that would continue to be provided by a Personal Edition license key.  Advanced features that require a Prosumer Edition or Professional Edition license key are also available, and provide a popup message letting you know that a Pro-only feature has been used.+  * Options > Preferences > Image Saving > "Copy metadata from source images ​to saved output images"​ 
 +  * Options > Preferences > Color Management > "Use input file profiles for ZS screen displays"​ 
 +  * Options > Preferences > Multiprocessing > "​Overlap I/O with computation if possible"​ 
 +  * Options > Preferences > Multiprocessing > "​Enable advanced undo"
  
 ===== Are program updates free? ===== ===== Are program updates free? =====
Line 169: Line 188:
 ===== How can I update the program? ===== ===== How can I update the program? =====
  
-Program updates are posted as new installers, on the regular [[http://​zerenesystems.com/​cms/​stacker/​softwaredownloads|Downloads]] and [[http://​zerenesystems.com/​cms/​stacker/​softwaredownloads/​currentbeta|Beta Downloads]] pages.+Program updates are posted as new installers, on the regular [[https://​zerenesystems.com/​cms/​stacker/​softwaredownloads|Downloads]] and [[https://​zerenesystems.com/​cms/​stacker/​softwaredownloads/​currentbeta|Beta Downloads]] pages.
  
 Just visit one of those pages and download the appropriate version for your type of computer. Just visit one of those pages and download the appropriate version for your type of computer.
Line 238: Line 257:
 ===== How do I save images as TIFF or JPEG? ===== ===== How do I save images as TIFF or JPEG? =====
  
-You need to use File > Save Output ​Images(s).  That will give you a choice of TIFF or JPEG, with options appropriate for each format (compression quality for JPEG, 8- versus 16-bit for TIFF).  ​+You need to use File > Save Output ​Image(s).  That will give you a choice of TIFF or JPEG, with options appropriate for each format (compression quality for JPEG, 8- versus 16-bit for TIFF).  ​
  
 It's a common mistake to use File > Save Project and then notice that what gets saved are .zsj and .zsy files that can't be used by anything besides Zerene Stacker. ​ File > Save Project is for tasks like coming back tomorrow to retouch an image that you generated today. ​ It stores images in lossless formats and keeps track of alignment information so that you can resume work immediately,​ with no expensive computation. ​ See [[http://​zerenesystems.com/​cms/​stacker/​docs/​howtouseit#​saving_work_in_a_project|Saving Work In A "​Project"​]] for more discussion about that. It's a common mistake to use File > Save Project and then notice that what gets saved are .zsj and .zsy files that can't be used by anything besides Zerene Stacker. ​ File > Save Project is for tasks like coming back tomorrow to retouch an image that you generated today. ​ It stores images in lossless formats and keeps track of alignment information so that you can resume work immediately,​ with no expensive computation. ​ See [[http://​zerenesystems.com/​cms/​stacker/​docs/​howtouseit#​saving_work_in_a_project|Saving Work In A "​Project"​]] for more discussion about that.
 +
 +If you have used File > Save Project and then left Zerene Stacker, you can quickly recover your work by launching Zerene Stacker again, doing a File > Open Project, and selecting the project folder or the .zsj file inside it.  After the project has been re-opened, you can select one or more images in the Output Images panel and use File > Save Output Image(s) to create TIFF or JPEG.  (Note: either the project folder or the .zsj file may show as a yellow smiling dog icon, depending on what operating system and program settings you're using. ​ If neither one shows the icon, just select the .zsj file anyway.)
  
 ===== Is there some way to save EXIF and other metadata? ===== ===== Is there some way to save EXIF and other metadata? =====
Line 352: Line 373:
  
 The effect can be worrisome when you first notice it.  However, the screen display appearance does not affect the quality of output image files, so once you realize what's going on, the worry goes away. The effect can be worrisome when you first notice it.  However, the screen display appearance does not affect the quality of output image files, so once you realize what's going on, the worry goes away.
 +
 +
 +===== Part of my subject looks transparent. What can I do? =====
 +
 +There'​s a whole separate page that addresses this problem.
 +
 +See [[https://​zerenesystems.com/​cms/​stacker/​docs/​tutorials/​stackselectedfortransparentforeground|"​Using Stack Selected to Retouch Transparent Foreground"​]] .
 +
  
 ===== How should I set the Alignment options? ===== ===== How should I set the Alignment options? =====
Line 406: Line 435:
  
 **Note:** If DMap does not pause for you to Set Contrast Selection, then go to Options > Preferences > DMap settings and remove the checkmark on "Use preset contrast threshold"​. ​ The software is distributed with that option not checked, but sometimes it gets checked by accident and then the lack of pause can be very confusing! **Note:** If DMap does not pause for you to Set Contrast Selection, then go to Options > Preferences > DMap settings and remove the checkmark on "Use preset contrast threshold"​. ​ The software is distributed with that option not checked, but sometimes it gets checked by accident and then the lack of pause can be very confusing!
 +
 +===== What is "​slabbing"​ ? =====
 +
 +Slabbing is a technique for making it easier to work with stacks that contain large numbers of images. The concept of slabbing is that you split your stacking into two big steps. ​ In the first step you might reduce say 200 original source images to 30 intermediate images, by stacking sets of 10-15 photos each, with some overlap between sets.  Then in the second step you stack the 30 intermediate images, the "slab outputs",​ to produce an image with the full stack combined. ​
 +
 +When you retouch with slabbing, typically you only have to reach back to the intermediate images, instead of all the way back to each of the original source images. ​ In the example, that means retouching from a set of only 30 images instead of 200.
 +
 +Slabbing can also be very helpful if you need to explore a variety of settings for the DMap parameters. ​ In this scenario you would generate the slab outputs using the PMax stacking method, then stack the slabs using DMap.  The gain here is much faster computation for the stacking, because DMap only needs to work with the much smaller number of slab outputs, instead of all the original source images individually.
 +
 +For more information about slabbing, see [[slabbing|HERE]].
 + 
  
 ===== Should I sharpen before or after running Zerene Stacker? ===== ===== Should I sharpen before or after running Zerene Stacker? =====
Line 412: Line 452:
  
 The same reasoning applies to noise reduction. ​ If you can reduce noise while preserving real detail, then that improves the signal-to-noise ratio and it's a good thing to do before running Zerene Stacker. ​ Just don't overdo it, again because fixing that problem would require reprocessing the whole stack. The same reasoning applies to noise reduction. ​ If you can reduce noise while preserving real detail, then that improves the signal-to-noise ratio and it's a good thing to do before running Zerene Stacker. ​ Just don't overdo it, again because fixing that problem would require reprocessing the whole stack.
 +
 ===== How can I detect movement in my stack? ===== ===== How can I detect movement in my stack? =====
  
-The easiest way is to "​play"​ the stack as it were a filmstrip. ​ To do this, just press-and-drag within the list of input files. ​ File selection will track the cursor, while the image shown in the source window will update to match. ​ This makes it easy to quickly find any portion of the stack that you are interested in, and at the same time makes it easy to joggle between two or three frames to identify the exact frame where some problem turns up.  ​+The easiest way is to "​play"​ the stack as if it were a filmstrip. ​ To do this, just press-and-drag within the list of input files. ​ File selection will track the cursor, while the image shown in the source window will update to match. ​ This makes it easy to quickly find any portion of the stack that you are interested in, and at the same time makes it easy to joggle between two or three frames to identify the exact frame where some problem turns up.  ​
  
 If you have already processed the stack, then you can also put a checkmark on "Show as adjusted"​ in the input files panel. ​ This will show the source images as they ended up after alignment. ​ This makes it much easier to spot movement of the subject. ​ Of course if you are interested in seeing how stable and well aligned your setup is, you will want to leave "show as adjusted"​ unchecked so that you're seeing the source images before alignment.  ​ If you have already processed the stack, then you can also put a checkmark on "Show as adjusted"​ in the input files panel. ​ This will show the source images as they ended up after alignment. ​ This makes it much easier to spot movement of the subject. ​ Of course if you are interested in seeing how stable and well aligned your setup is, you will want to leave "show as adjusted"​ unchecked so that you're seeing the source images before alignment.  ​
Line 468: Line 509:
  
   * If a stack is shot as raw, then very rarely, some raw conversion software will make slight changes in the image size apparently at random. ​ Again, a good fix is to set Options > Preferences > Preprocessing > "Image Pre-cropping"​ to be the size of the smallest image produced by raw conversion. ​ As an alternative,​ try turning off distortion correction in your raw converter. ​ Lens distortion can change with focus, prompting the raw converter to output slightly different image sizes.   * If a stack is shot as raw, then very rarely, some raw conversion software will make slight changes in the image size apparently at random. ​ Again, a good fix is to set Options > Preferences > Preprocessing > "Image Pre-cropping"​ to be the size of the smallest image produced by raw conversion. ​ As an alternative,​ try turning off distortion correction in your raw converter. ​ Lens distortion can change with focus, prompting the raw converter to output slightly different image sizes.
 +
 +===== When do Options > Preferences values get saved and reloaded? =====
 +
 +Whenever the program exits, it writes current preferences to a configuration file, named "​zerenstk.cfg"​. ​ The next time the program is launched, it reads those saved preferences from zerenstk.cfg .  All preference values that relate to stacking, file formats, etc. are also written to each project file (*.zsj) that is created or updated by File > Save Project. ​ Whenever a project is reloaded by File > Open Project, all the preferences of that project also become the current preferences of the program. ​ So, when the program exits after reloading a project, the preferences that are saved to zerenstk.cfg will be the values belonging to that project, not whatever preferences were set before the project was reloaded. ​ Preferences can also be explicitly saved and restored, independent of any project, by using the "Save preferences..."​ and "Load preferences..."​ buttons in the Options > Preferences panel.
 +
 +Most of the time, you can just ignore all these details and the program will do what you expect it to do.
 +
 +However, there are a few situations where the program'​s handling of preferences can produce unpleasant confusion. ​ Perhaps the most common one is when you've been doing some stacking, then you reload an old project for whatever reason, then you start a new project without realizing that the old project had different preference settings and now you're using those again!  ​
 +
 +If you frequently change preferences and reload old projects, then it's probably good to get in the habit of explicitly saving and loading preferences by using the buttons in the Preferences panel.
  
 ===== What are some tips for fast retouching? ===== ===== What are some tips for fast retouching? =====
Line 545: Line 596:
 \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\
  
-VPS 
  
stacker/docs/faqlist.1570060840.txt.gz · Last modified: 2019/10/03 00:00 by rjlittlefield
Copyright 2009-2020, Zerene Systems LLC, all rights reserved.