Zerene Stacker

Differences

This shows you the differences between two versions of the page.

stacker:docs:howtouseit [2011/07/04 00:24]
rjlittlefield
stacker:docs:howtouseit [2020/04/06 22:19] (current)
rjlittlefield [Batch Processing] Revise for new dialog layout
Line 118: Line 118:
 ===== Saving Work In A “Project” =====  ===== Saving Work In A “Project” ===== 
  
-Using a “project” in Zerene Stacker lets you leave the program, get back inand pick up working where you left off.  The project contains links to the input images, alignment and brightness adjustments, and copies of the output images stored in a proprietary lossless format suitable for subsequent processing.+Saving a “project” in Zerene Stacker lets you leave the program, then quickly get back in and resume working where you left off.  project contains links to the input images, values of alignment and brightness adjustments for each input image, copies of the output images stored in a proprietary lossless format suitable for subsequent processing, and most of the Options > Preferences settings that were in effect at the time the project was saved.
  
-In the computer’s file system, each Zerene Stacker project consists of a directory of filesone of which has file type “.zsj”  +Many people never use File > Save Project.  If you're sure that you have an image completed to the point where you're done using Zerene Stacker, then you can just File > Save Output Image to create a TIFF or JPEG file, and all the other information will be thrown away when you exit the program.
  
-With default settingsnew projects are initially created with a temporary name in a temporary location.  Saving a project involves simply renaming the directory and .zsj file if possible, or copying if necessary.  Other options and directory locations can be set under Options &gtPreferences &gtNew Projects.+But if you think you might want to do some more retouchingthen it's better to File > Save Project until you're sure that you really are done.  Some people retain their projects forever; other people delete them at some point to save disk space. 
 + 
 +In the computer’s file system, each Zerene Stacker project consists of a folder containing a ".zsj" file and several subfolders.  The .zsj file is the master description for the project.  You can look inside it with any text editor.  Typical subfolders include "generatedimages", which contains output images in ".zsy" format; "previewimages", which contains cached screen preview images as low quality ".jpg"; "AdjustedSourceImages" if Save Adjusted Images has been used; and so on.
  
 <html><a name="_Batch_Processing"> </a></html> <html><a name="_Batch_Processing"> </a></html>
Line 133: Line 135:
 In the following example, the user has defined one batch, consisting of 7 folders of source images.  A new project will be constructed for each folder of source images, PMax and DMap will be run within each project, the projects will be saved in a designated location, and output images will be both retained within the projects and written to external files.   In the following example, the user has defined one batch, consisting of 7 folders of source images.  A new project will be constructed for each folder of source images, PMax and DMap will be run within each project, the projects will be saved in a designated location, and output images will be both retained within the projects and written to external files.  
  
-{{:stacker:docs:howtouseit:image010.jpg}}+{{:stacker:docs:howtouseit:image010v2.jpg}}
  
-For batch usage, the appropriate contrast threshold for DMap is best determined by running a typical stack interactively.  Then you can set Options &gtPreferences to apply that same threshold unattended to all folders in the batch.+Pressing the &quot;Save Batch to Queue" button causes the bottom panel of the Batch Queue dialog to update so that it looks like this:
  
-{{:stacker:docs:howtouseit:image011.jpg}}+{{:stacker:docs:howtouseit:image010p5v2.jpg}} 
 + 
 +At this point, pressing the "Run All Batches" button will cause the indicated tasks to be run against the indicated folders or projects.  (Note the ordering, "tasks: folders" .) 
 + 
 +In the Batch Queue dialog, the “Add Current Project” button has two different uses, as follows:  
 + 
 +  - If the currently open project has been saved at some point and thus has a well-defined name, then that name is simply recorded.  This allows a sequence of batch operations to be constructed incrementally, by opening a project and specifying tasks to be done with it, then opening a different project, specifying tasks for that project, and so on.  In this case, the batch queue entries will look something like this: \\ {{:stacker:docs:howtouseit:image012v2.jpg}} \\ \\  
 +  - If the currently open project is new and has never been saved, then pressing Add Current Project records the target as “%CurrentProject%”. Batch operations defined in this way can be executed on multiple different projects at various times.  This feature is particularly useful in combination with Save Batch Script and Load Batch Script.  In this case, the batch queue entries will look like this: \\ {{:stacker:docs:howtouseit:image013v2.jpg}}
  
 Note that each task may have different options (preferences) set for it.  The task records whatever Options > Preferences are in effect at the time the Add button is pressed.   Note that each task may have different options (preferences) set for it.  The task records whatever Options > Preferences are in effect at the time the Add button is pressed.  
Line 143: Line 152:
 The options for a task can be confirmed and/or changed by highlighting the task and pressing Change Options.  Options can also be displayed in a textual form by highlighting a task and pressing Details. The options for a task can be confirmed and/or changed by highlighting the task and pressing Change Options.  Options can also be displayed in a textual form by highlighting a task and pressing Details.
  
-In the Batch Queue dialog, the “Add Current Project” button has two different uses, as follows: +For batch usage, the appropriate contrast threshold for DMap is best determined by running a typical stack interactively.  Then you can set Options > Preferences to apply that same threshold unattended to all folders in the batch.
  
-  - If the currently open project has been saved at some point and thus has a well-defined name, then that name is simply recorded.  This allows a sequence of batch operations to be constructed incrementally, by opening a project and specifying tasks to be done with it, then opening a different project, specifying tasks for that project, and so on.  In this case, the batch queue entries will look something like this: \\ {{:stacker:docs:howtouseit:image012.jpg}} \\ \\  +{{:stacker:docs:howtouseit:image011v2.jpg}}
-  - If the currently open project is new and has never been saved, then pressing Add Current Project records the target as “%CurrentProject%”. Batch operations defined in this way can be executed on multiple different projects at various times.  This feature is particularly useful in combination with Save Batch Script and Load Batch Script.  In this case, the batch queue entries will look like this: \\ {{:stacker:docs:howtouseit:image013.jpg}} +
-  +
-Similarly, the setting for disposition of output images to “Save in source folder” does different things depending on the target of the batch operation, as follows:+
  
-  * If the target is a folder of source images, then output images will go into that folder.   
-  * If the target is a new project and “New projects are temporary (do not save)”, then output images will go in the folder of the first source image.  
-  * If the target is a project that has already been saved or will be saved as a result of “Disposition of new projects”, then output images will go in the root of the project folder.  
  
 The batch capability can also be used to provide an API (Application Programming Interface) that allows Zerene Stacker to be controlled by another application such as [[http://rsbweb.nih.gov/ij/|ImageJ]] or a command script.  For details, see, **[[:stacker:docs:batchapi|Batch API: Running Zerene Stacker From Another Application]]**. The batch capability can also be used to provide an API (Application Programming Interface) that allows Zerene Stacker to be controlled by another application such as [[http://rsbweb.nih.gov/ij/|ImageJ]] or a command script.  For details, see, **[[:stacker:docs:batchapi|Batch API: Running Zerene Stacker From Another Application]]**.
stacker/docs/howtouseit · Last modified: 2020/04/06 22:19
Copyright 2009-2019, Zerene Systems LLC, all rights reserved.