Zerene Stacker

Zerene Stacker Modification History

Current Beta

The current beta release is version T201711041830_beta (November 04, 2017).

It is functionally equivalent to the full release T201711041830.

Current Full Release

The current full release is Build T201711041830 (November 04, 2017).

Improvements in T201711041830 and T201711041830_beta

  • User interface
    • Make announcements and update notifications be close to default font size on high-res displays.

Improvements in T201710301100_beta

  • Added function “Re-order input files > “Sort by Scale”.
  • Updated Mac binaries to avoid deprecated libstdc++, side effect is that StackShotHelper now requires MacOS 10.9 or above in standard distribution.
  • User interface
    • Avoid redundant warning about existing file, when saving with native file chooser.
    • Batch dialog
      • Remove “Add Projects and Folders” button unless JFileChooser is used.
      • Diagnose and avoid adding individual image files to batch dialog.
    • Make splash screen, Options > Registration, and Console Log windows use same size font as the rest of the application.
    • Provide an automatic Restart button for changes to Look & Feel.
    • Use default font size even for high-res displays, with Windows & Mac native L&F's.
  • Installation option
    • License key can be located in application root directory.
  • Bug fixes:
    • Default file name was not showing in some saves with system native file chooser.
    • Directory selection was not working in some cases with system native file chooser.
    • File saving parameters could not be changed by using the accessory panel in a JFileChooser dialog.
    • In the StackShot controller step sizes panel, sometimes could not Save or Load using system native file chooser.
    • On Mac, diagnostic dialogs were occasionally hidden behind the Options > Preferences or Batch Control dialog windows.
    • DMap contrast threshold panel was too big sometimes.
  • Update embedded JRE to version 8u144 (jre1.8.0_144)

Improvements in T201708112041_beta

  • PMax: added feature to retain only the UDR image, not the normal PMax.
  • User interface
    • Allow arbitrarily narrow left panel in main window (input/output lists).
    • Reword tooltip for option “Retain extended dynamic range”.
  • MacOSX bundle: make all executables 64-bit.
  • Bug fixes:
    • Allow ”+” character in all file paths.
    • Handle spurious /u2028 (Unicode “LINE SEPARATOR”) in license keys.
    • Mac, avoid hiding batch dialog while adding tasks.
    • Batch dialog, disable Paste button when not appropriate to press.
    • Avoid red popup message when selecting directory with native file chooser.
    • On Mac, physical memory “Detect” button sometimes could not be activated.
    • Revert to HTTP to avoid SSL certificate problems with old JREs.
    • Macintosh “Keep in Dock” menu entry would make an icon for java instead of Zerene Stacker.

Improvements in T201706041920_beta

  • Bug fix: force 8-bit color for JPEG even if specified otherwise.

Improvements in T201706022100 and T201706022100_beta

  • Bug fixes in StackShot robot:
    • Mouse release and mousewheel commands not issued correctly.
    • “DL” not honored as shortcut for “Delay”.
  • Bug fix: difficult to select a folder using native filechooser.
  • Bug fix: Batch dialog sometimes treated user interface hint as folder name.
  • User interface:
    • Batch dialog, reorganized for top-to-bottom workflow.
    • DMap preferences, label depth map target as “folder” not “directory”.

Improvements in T201705122140 and T201705122140_beta

  • Bug fixes:
    • Linux and Macintosh launchers now work when executed from PATH or symbolic link.
    • Save multiple output images now works with native file chooser dialogs.

Improvements in T201705042151_beta

  • User interface
    • Use system native file chooser dialogs by default.
    • Provide option to use JFileChooser as in previous versions.
    • Rename configuration option for using augmented JFileChoosers.
    • Allow drag-and-drop or paste folders into Batch Dialog.
    • Change word “directory” to “folder” in user interface.
  • Use https protocol for update checks.

Improvements in T201704232247_beta

  • Bug fix: workaround for Windows 10 Creators Update problem that causes silent crash in JRE when Java look-and-feel is Windows native.
  • Bug fix: avoid exception writing watermarks with expired license
  • User interface
    • Reorganize image saving parameters panel for better top-to-bottom flow.
    • Improve diagnostic when Lightroom plugin cannot find ZS executable.
    • Move DMap mask color chooser to toolbar.
  • Update embedded JRE to version 8u121 (jre1.8.0_121)

Improvements in T201702042021_beta

  • In Preferences > DMap Settings, move Set Default button to top.
  • Introduce “Set mask color” button in toolbar when DMap slider is visible.
  • Avoid memory allocation problems caused by externally defined _JAVA_OPTIONS.
  • Avoid reading EXIF orientation if result will be ignored.
  • Bug fixes
    • OK button in DMap slider dialog was sometimes not focused at start.
    • On Mac, Enter key did not work to “click” a focused button.
  • Allow ALT as equivalent for S, as flash-to-source in retouching.
  • Add missing keypress detector to catch S-to-flash failure on Macs.
  • Parameters added for debugging missing keypress problem on Macs:
    • RetouchingManager.DisableCoalescing=true
    • RetouchingManager.FocusPollMillis=<number>
    • Developer.RequestFocusOnKeyReleaseMillis=<number>
    • Developer.EnableExtremeLogging=all
    • RetouchingManager.FlashSourceDelayMillis=<number>
    • Printouts for focused component and key listeners

Improvements in T201611152030_beta

  • Update embedded JRE to version 8u112 (jre1.8.0_112)
  • Lightroom plug-in
    • Allow nominal print resolution to be specified in export panel.
  • File saving
    • Add option to save TIFF files with LZW compressions
    • Rearrange panel for Options > Preferences > Image Saving parameters.

Improvements in T201610272136_beta

  • Image file compatibility
    • Accept invalid ICC profiles (typically produced by Capture One raw converter when used with its setting to “Embed camera profile”)
  • User interface
    • Add preferences to increase font size for menus and all other text elements.
    • Select OK button for default when Options > Preferences panel is opened.

Improvements in T201607231703_beta

  • User interface
    • Add Look & Feel option to specify a pixel replication factor, for smoother images on high-DPI displays such as Apple Retina.
    • Fix updating bug in percentile spinner, DMap contrast threshold dialog.

Improvements in T201607192239_beta

  • User interface:
    • Introduce first cut of internal mods working toward user-selectable color to use instead of black, in DMap contrast threshold preview.
    • In contrast threshold slider panel, allow user to directly specify the Percentile value.
    • Change common modifier for keyboard shortcuts from ctrl to cmd on Mac.
    • Do not abort if configuration file is corrupted to contain illegal name.

Improvements in T201605221655_beta:

  • User interface:
    • Preserve size of filechooser navigation panels between uses (when Options > Preferences > Look & Feel > “Reset layout for each project” is not selected).
    • Preserve size of DMap contrast threshold dialog between uses, if not reset.
    • Add keyboard shortcuts and accelerators for commonly used menu operations.
    • Add menu entries with shortcuts to select each of first 9 output images.
    • Added keyboard alternates “8” and “9” to adjust image scale and retouching brush size (for international keyboards that don't have keys for ”[” and ”]”).
    • Set keyboard focus on DMap slider OK button when dialog opened, to allow pressing button from keyboard.
    • Allow selecting strategy for initial folder selection on Save Output Image(s), “with source files”, “in previous folder”, and “in specified folder”.
  • Image alignment:
    • Added Lanczos 5, 6, 7 (filling in the full range from 2-8).
    • Added facility to align each image separately against the first image, instead of incrementally against the previous image as aligned.
  • Bug fixes:
    • Avoid red exception in EXIF propagator if source images cannot be found.
    • Be sure that DMap contrast threshold dialog is big enough to show OK button.
    • Fix problem with tiny knob on Windows 10 DMap slider.
    • Reset main horizontal divider when layout reset.
  • Platform update:
    • Prepare for long term anticipated change from “Mac OS X” to just “Mac OS”.

Improvements in T201602151850:

  • Bug fix:
    • Lightroom plugin, work around newly introduced Adobe bug on Macintosh, which caused temporary folders to be named just “2” instead of “Lightroom_Export_to_ZereneStacker_<timestamp>”.
    • Avoid red popup in certain cases of toggling image caching in existing project.

Improvements in T201512132102_beta:

  • Performance improvement:
    • Screen preview images cached in memory if space available.
  • User interface:
    • New display Help > Show Memory Usage…, enabled by Look & Feel option.
    • When installing a license key, handle more email corruptions.
  • Bug fixes:
    • Extensive rework of thread synchronization to avoid occasional freezes, especially when entering retouching or changing window sizes.
    • Option settings and other parameters sometimes would not be saved if a project was open when the software exited.
    • Avoid red popup in some cases of Align All Frames with “Show as adjusted”.
    • Lightroom plugin on Mac, use fully qualified ”/usr/bin/open” if possible.
    • Lightroom plugin, default to original source folder for image saves even if the project is saved and re-opened.
    • More accurately preserve sizes of image windows across exit / relaunch.
    • Maintain current state if user requests to close a project and then cancels that when asked.
    • Brush controls panel, automatically revert to details brush if “More brushes” becomes unselected.
    • Query for modified project on close while retouching.
    • Disable “Stack New Images (PMax)” menu entry while retouching.
    • Add defensive assertions for Swing calls not on the event thread.
    • Automatically move image window to front when maximized.
    • Stereo preview, properly match scale if entered when output window is resized and image scale is fit to window.
    • Redundant update of Lightroom plugin if multiple launch without exit.
    • Redundant notification if manual launch after auto restart without exit.
    • Explicit deletion of temporary file for EXIF tags.
    • Explicit deletion of temporary file for retouching undo.

Improvements in T201511081944_beta:

  • Lightroom plug-in:
    • Retain location data such as GPS info in EXIF.
    • Faster export if plug-in temp files are on same volume as LR temp folder.
    • Faster project saving if plug-in temp files are on same volume as project.
    • Automatically update LR plug-in files on first execution of new version.
    • Explicitly confirm user deletion of plug-in.
    • Avoid silent failure if disk full.
    • Do not persist LR plug-in settings as part of project.
    • Automatically remove temporary image files if export is canceled.
  • PMax stacking method:
    • Add option to make decisions based on all color channels, instead of just luminosity.
  • User interface:
    • Remember/restore window status: iconified/normal/maximized.
    • Automatically force window back onto screen if graphics configuration changes between exit and relaunch.
  • Bug fixes:
    • Automatically fall back to “Do not manage color”, for grayscale source profiles that are incompatible with RGB output.
    • Macintosh: prevent disk root name from appearing as default project name on Save Project.

Improvements in T201510021255

  • User Interface:
    • Automatically forget trials over 1 year old.
    • For expired trials, list the relevant date.
    • Clarified label in batch dialog, regarding “as sourcename_…”
    • Adjusted interpolator box size to show entire names.
    • In retouching mode:
      • Only allow single selection of source images.
      • In fast navigation mode, allow scrolling of source list.
      • Disable gamma slider when checkbox is deselected.

Improvements in T201509121155

  • User Interface:
    • Improved warnings and diagnostics for problems entering a license key.

Improvements in T201509101925_beta

  • User Interface:
    • Improved support for Pro-only features with extended-trial license keys.
    • Update default preferences immediately when new license key is installed.
    • Disable load and append of batch scripts when a batch job is running.
  • Update embedded JRE to version 8u60 (jre1.8.0_60)
  • Bug fixes:
    • Running a batch task could disable preference changes.
    • Incorrect interpolated pixel values near right edge of source frame.
    • EXIF sporadically missing some IPTC fields

Improvements in T201507251110_beta

  • EXIF
    • Bug fix: properly handle multiple inconsistent exposure time tags.

Improvements in T201507221224_beta

  • EXIF
    • Honor EXIF Orientation when reading image files, with option to ignore as was done previously.
    • Bug fix: allow ”+” character in file & folder names.
  • Lightroom plug-in
    • Bug fix: avoid removing temporary image files if user starts to close project and then says no keep it open.

Improvements in T201507101645_beta

  • EXIF metadata
    • New feature controlled by Options > Preferences > Image Saving > “Copy metadata from source images to saved output images”.
    • Feature is automatically selected by default in Prosumer and Professional editions, and if Zerene Stacker has been launched through the Lightroom plug-in. Otherwise it must be explicitly selected by the user as a Pro-only feature to be trialed.
  • User interface:
    • Renamed the file saving option to be “Retain extended dynamic range”, instead of the old and often misleading “Retain full dynamic range”.
    • Note in console log whenever specified batch file cannot be read.
  • DMap:
    • Now allows to import a mask file that augments the contrast threshold slider.
      (This feature is an early version slated to be expanded, but it can be useful even in its current form for dealing with some kinds of subjects such as white flowers against a uniform dark background. See Options > Preferences > DMap Settings > “Use external mask”.)
  • StackShot rail
    • Bug fix: FWD/BACK buttons did nothing in some high resolution configurations.

Improvements in T201501142140_beta

  • Bug fixes:
    • Batch would treat a parameter specified in the script as absent if its value was equal to the standard default.
    • Fall back to minimal undo instead of red popup error, if memory is very tight when retouching begins.

Improvements in T201412212230 and T201412212230_beta

  • Lightroom plugin
    • Improved checks on invalid folder names and problems writing scripts.
    • Bug fix: temporary images folder not honored.
  • StackShot rail
    • Add button to Pause while shooting a stack.
    • Remember positions for Start and End of stack.
    • Add Mac support for new format serial numbers.
    • Cleanly abort stack if controller window closed while shooting.
    • Bug fix: Zerene Stacker could hang on exit after StackShot controller was opened and closed.

Improvements in T201411272115 and T201411272115_beta

  • User interface cleanups
    • Explicitly acknowledge acceptance of a license key.
    • In case of expired trial or expired license, provide better options for visiting the website or installing an existing license key.
    • 32 bit Windows memory allocation, allow to skip automatic search.
    • Warn if running 32-bit Zerene Stacker on 64-bit Windows.
    • Save log files in some odd cases that would have been skipped.
    • Disable save-adjusted menu entry if expired trial.

Improvements in T201411201955_beta

  • Cleaned up workflow for memory allocation, especially for new users.
  • Added and improved checks for low memory conditions.
  • Enable external TIFF reader in Linux packages.
  • Provide StackShot controller in Linux packages.
  • Look & Feel:
    • Added option to suppress splash screen on launch.
    • Added option to suppress memory allocation hints.
  • Bug fixes:
    • Save StackShot configuration even if controller window is open on exit.

Improvements in T201411062121_beta

  • Update embedded JRE to version 8u25 (jre1.8.0_25)
  • Macintosh: restructure distribution package to be self-contained.
  • Bug fixes:
    • Avoid hang on warnings and errors from the external TIFF reader.
    • 16-bit compressed TIFF, do auto fallback to external TIFF reader.

Improvements in T201410151258_beta (limited distribution)

  • StackShot controller:
    • Talk to StackShot3x.
  • Lightroom plugin:
    • Automatically close dialog after successful creation.
    • Allow user to specify location for temporary files.
  • Bug fixes:
    • Handle additional forms of corrupted license key formats
    • Avoid unnecessary re-alignment on Stack Selected when Brightness correction is not selected.
    • Correct for Mac bug of presenting corrupted color profiles that contain one extra byte of garbage.
    • Avoid holding a zip archive open after accesses are finished.
    • Avoid attempting to add hidden files.
    • Avoid attempting to add files with names ending in ”.DS_”.
    • StackShot controller: avoid exception for negative sleep time.
    • StackShot controller: remove slight rail motion on Shutter press.
    • StackShot controller: show action “firing shutter” on Shutter press.

Improvements in T201404082055 (the previous full release version)

  • Lightroom plugin: added ability to set the default colorspace.
  • Lightroom plugin: added ability to delete the installed plugin.
  • By default, automatically honor colorspace in Zerene Stacker's own screen displays when running as Lightroom plugin.
  • Bug fixes:
    • Avoid crash if specified crop region is larger than input image.
    • Update appearance of input image when option to use input profile is changed.

Improvements in T201404051400_beta (limited distribution)

  • Added ability to crop source images during preprocessing.
  • User interface:
    • Option to not show JPEG/TIFF preferences panel when saving output images.
    1. * Added config parameter UIStyle.IncludeThreadNumbersInConsoleLog .
  • Bug fixes:
    • Avoid random corruption of images when simultaneously resizing with any Lanczos kernel and overlapping I/O with computation.
    • Allow skipping an image with mismatching size during stacking.
    • Avoid thread timing issue that was causing an assortment of problems with window sizes when the screen layout changed for retouching etc.

Improvements in T201403071805_beta

  • Increased Speed:
    • Much faster computation of depth map after threshold selection.
    • New option to use less resources displaying in-progress results while stacking. (Look & Feel > “Set output display interval”, pro-only).
  • User interface:
    • Image displays can now honor color profiles, so images using AdobeRGB and ProPhotoRGB will display in natural colors. This is a Pro-only option, enabled by checkbox at Options > Preferences > Color Management > “Use input file profiles for ZS screen displays”.
    • New option to disable warnings when starting trial of pro-only features.
    • Look & Feel preferences are now wrapped in a scroll pane.
    • File > Save Project is now enabled even for new projects. (It automatically does a File > Save Project As… in that case.)
  • Bug fix:
    • Address occasionally disabled menus after Help > Check For Update.

Improvements in T201402252210_beta

  • Increased Speed:
    • Improved handling when all alignment parameters are not selected.
    • Improved parallelization of alignment computation.
    • Reduced memory management overhead during stacking.
    • Option to overlap I/O and computation if sufficient memory (pro-only)
    • Avoid certain computations if screen image caching is not selected.
  • Bug fixes:
    • Avoid rare crash with extreme brightness correction.
    • Avoid slight drift in brightness correction if stack was repeatedly processed.
    • Replace incorrect example of output image naming template.
    • Windows: write console output log using DOS line endings.

Improvements in T201402072140

  • Integration: rebuilt with current JRE 1.7.0_51 and freshly updated tools.
  • Lightroom plugin: added this new capability.
  • Bug fix: do not leave image file open after reading.

Improvements in T201311272225

  • Alignment: improve accuracy of Align & Stack All.
  • Add files & folders: ignore files that are hidden with ”._” names.
  • UI: remove input and output image windows when no project is open.
  • UI: add “or folders” to the prompt for drag-and-drop input files.
  • UI: add taskbar entry when waiting for user action on expired trial.
  • UI: clean up format of license keys that are corrupted by email.
  • UI: clarify message on first use of Pro-only features.
  • UI: allow to skip update notifications for specific version
  • UI: allow for notifications other than new version
  • UI: Added menu entry Help > Check For Update.
  • Bug fix: remove spurious log entry about redundant dispose.
  • Bug fix: remove spurious warning on last option in batch dialog for saving output images.
  • Bug fix: update menus immediately when any Pro license is installed.

Improvements in T201305212130

  • Licensing: changed embedded license to include Prosumer Edition and new clauses that allow Personal and Prosumer to be used for education.
  • Added {sourcefolder} option in output image naming template.
  • UI: changed tooltip on “Retain UDR Image”.
  • UI: added tooltips for StackShot main panel controls.
  • Stackshot: “Shutter” button now runs external trigger commands also.
  • Bug fix: automatically close batch dialog to avoid hiding DMap slider.
  • Bug fix: accept localized format for fractional scale in image display.
  • Bug fix: show “Use all cores/processors” button when cores=2.
  • Bug fix: erroneous check for “Cannot save project into itself”.

Improvements in T201305092335

  • DMap: contrast threshold panel stars centered on main window.
  • Bug fix: keep Stack Selected options visible in batch tasks dialog.
  • Bug fix: infinite recursion in task parameters for some Batch jobs.
  • Bug fix: fix insanely large brush diameter at start of retouching.

Improvements in T201304300920

  • Bug fix: remove mousetrail during initialization of retouching.

Improvements in T201304292302

  • Bug fix: Mac version, properly honor “No, leave project open”.

Improvements in T201304051302

  • Bug fix: automatically retry with internal reader if external TIFF reader fails.
  • Bug fix: typo in #header of launch script.
  • To facilitate regression testing:
    • Removed tiny randomness in alignment from run to run.
    • Set names inside JSpinner components.
    • Tweak console log capturing.

Improvements in T201303232145

  • When -runMinimized
    • Push progress window to front harder and with slight delay.
    • Log SHOWPROGRESS indicators for use by calling program.

Improvements in T201303212150

  • Batch mode: if parameters are not specified in batch tasks, then inherit them from earlier tasks or application state.
  • Bug fix: too many keyboard focus requests

Improvements in T201303162040

  • UIStyle.SuppressDoubleBuffering=true :
    • Added display capability diagnostics.
    • Reduced flashing when brushing in retouching mode.
  • Bug fix: menu entries occasionally gray even though enabled (on change of application focus).

Improvements in T201303132055

  • Bug fix: menu entries occasionally gray even though enabled (after close of dialog box).
  • Bug fix: update Mac external TIFF reader to accept commas in pathnames.
  • Added support for license category “Prosumer”.

Improvements in T201303122140

  • Added onscreen progress bar by default when -runMinimized.
    • With optional runtime parameter -showProgressWhenMinimized=false if new onscreen progress bar is not wanted.
    • Text settable by optional zerenstk.cfg parameter and default “UIStyle.ProgressWindowText=Please wait, processing.”
  • Can override UIStyle.ProgressWindowText Optional using optional runtime parameter -progressWindowText=“any text”
  • Suppress automatic update check when -runMinimized
  • Bug fix: print ' instead of \' from license keys.
  • Added zerenstk.cfg parameter UIStyle.SuppressDoubleBuffering=true to possibly avoid some display driver bugs
  • Bug fix: print ' instead of \' from license keys.
  • Bug fix: unable to select generic CubicA interpolator.

Improvements in T201303050955

  • Stack New Images
    • Stack > Stack New Images will create new project if needed
    • Added option to accept newest file after fixed delay
    • Automatically open Options dialog to specify watch folder if needed.
    • Look & feel: changed wording “watch directory” to “watch folder”.
    • Bug fix: early termination with “Stack every N'th frame” > 1
  • Added look-and-feel options to not warn about closing a modified project.
  • External tiff reader: improved backward compatibility in build script.

Improvements in T201303012035 (a full release version)

  • On Linux, allow execution from any directory without modifying the launch script.
  • On Mac, revert to previous build of external TIFF readerto avoid undiagnosed incompatibility on some computers.

Improvements in T201302191410 (summary since T201207281315)

  • Retouching
    • Added “undo” capability. [basic in Personal; extensions in Pro only]
    • Added new brush types that copy pixel values instead of details. [Pro only]
  • Advanced interpolation kernels [Pro only]
    • Added Lanczos 3 and Lanczos 8 interpolators.
    • Added “CubicA” 4×4 kernel with tunable sharpness.
    • Added 4×4 kernels tuned to match Lanczos3 and Lanczos8 sharpness.
    • Added {rkernel} tag in output image naming template.
  • Ignore empty files in watch directory.
  • Added option to “Add file to existing project as already aligned” to facilitate slabbing.
  • Updated StackShotHelper for use with FTDI's D2XX 1.1.12 drivers.
  • Update embedded runtimes to jre1.7.0_11 .
  • Improved alignment algorithm to avoid getting stuck at zero in some unusual cases.
  • “Close” button on Options > Preferences now requires OK or Cancel only if options have been changed.
  • Bug fixes
    • Corrected version string in Macintosh “About Zerene Stacker”.
    • License keys with non-ASCII characters now work even if corresponding font is not installed on the execution platform.
    • Removed duplicate folder name in Save Adjusted paths.

Improvements in T201207281315 (summary since T201110101145)

  • Incorporate code signing for Windows installers.
  • New features in StackShot controller:
    • Added provision for table of predetermined step sizes.
    • Added buttons to move forward and backward by one step.
    • Added configuration parameters to set rail positions at left and right of the rail position indicator bar.
    • Release connection to StackShot when window is closed.
    • Added “Zero” button to reset StackShot rail origin.
    • Improved diagnostics for difficulties in StackShot communications.
  • Added a Pro-only feature to save to a TIFF file the depth map that was generated by DMap stacking.
  • UI changes:
    • Mouse wheel forward now makes image bigger, not smaller.
    • Added explicit feedback popup on Save Project.
  • Bug fixes:
    • Allow .zsy files > 2 GB (image size > 178 megapixels).
    • Avoid exception or very slow load if project references image files that are on an unmounted device.
    • Avoid erroneous deletion of a .zsy file if an output image is removed and recreated with the same name in the same run.
    • In batch dialog, correctly report task as “Stack Selected (DMap)” instead of “Align Selected (DMap)”.
    • Alter image painting to avoid hang in retouching with latest Macs.
    • Add retry on cache files, to tolerate interference by continuous backup and indexing utilities.
    • Avoid occasional screen layout errors due to updating off the event thread.

Improvements in T201110101145

  • Added a launch parameter -Dlogging=false , to help debug rare situations in which launch fails without diagnostic.

Improvements in T201110101105

  • Added tags in template for naming output images, to make names that contain parameter values for DMap, alignment control, and every N'th frame.

Improvements in T201109192220

  • Changed default DMap Settings to be Estimation Radius = 10 and Smoothing Radius = 5, which work better for new users and 10+ megapixel cameras. (The old defaults were Estimation Radius = 5 and and Smoothing Radius = 2.)
  • Automatically adjust Smoothing Radius to match Estimation Radius in DMap settings.
  • Add Preferences > Preprocessing option to stack every N'th frame.
  • Bug fix: prevent two popup dialog windows from getting hidden behind others.
  • Bug fix: contrast threshold percentile was remembered as 0 if the slider was never touched.

Improvements in T201109150905

  • StackShot: add “prerun distance” to automatically take up backlash in the lead screw when going to start or end, or shooting a stack, even if the exact backlash distance has not been determined.
  • Use bracket keys ”[]{}” to adjust image scale when the hand cursor is showing. (This is in pan-tool mode, entered by pressing the spacebar.)
  • Bug fix: issue coherent diagnostic if an invalid path is specified when saving an image file.

Improvements in T201108291210

  • Bug fix: Macintosh, address UI hang if user has switched desktops (spaces) when ZS pops up a modal dialog.
  • Bug fix: avoid inactive retouching brush caused by absence or loss of shift-release event.

Improvements in T201108221250

  • Macintosh: do not need to install drivers in /usr/local/lib.

Improvements in T201108220910

  • Bug fix: allow special license keys that avoid trial checking, to work around a rare issue accessing the Windows registry.
  • Bug fix: eliminate resource leak in zshelper app.
  • Bug fix: support Mac OS X 10.7 in selecting StackShot drivers.

Improvements in T201108102145

  • Bug fix: diagnose error instead of “unexpected condition” if Watch directory is never specified for Stack New Images.

Improvements in T201108020545

  • Bug fix: automatically retry and Use External TIFF Reader for remainder of the current execution, if ImageIO fails to read TIFF due to the Java readBytes memory bug.

Improvements in T201107102045

  • StackShot controller: added “robot:” facility to allow generating synthetic mouse and keyboard actions as a way of communicating with another running program, instead of launching an external trigger command.

Improvements in T201107101715

  • StackShot controller: work around bug in FTDI 2.8.14 driver causing occasional communication errors.
  • Bug fix: if Options > Preferences > Alignment is changed while retouching, then diagnose but don't crash.

Improvements in T201107060120

  • StackShot controller:
    • improved robustness to transient communication errors,
    • extended logging of rail control parameters.
  • Files rejected during drag-and-drop are now logged.
  • Bug fix: memory usage tracking works with >2GB allocation.

Improvements in T201106271925

  • Bug fix: avoid “won't brush” condition caused by navigating away from one input file and then back to the same file while shift is held down.

Improvements in T201106252220 (Beta)

  • Bug fixes:
    • Remove inadvertent pop-forward-and-steal-keyboard when an output image is completed.
    • Prevent occasional ignoring of keyboard in retouching mode when mouse was held still after a button press.
    • Diagnose source files still missing after user attempts to locate them by browsing
    • Prevent filechooser from descending into previously saved project when two Save Project's are done in the same session.

Improvements in T201106111240 (Beta)

  • Save Other > Save Adjusted Input Images added as new capability (Professional Edition only).
  • Detect source files moved or deleted since project was created, allow user to locate them by browsing.
  • Allow .szj project files to be drag-and-dropped onto Input Files panel.
  • File names containing variable-length numbers are now sorted according to Windows convention: img3.jpg before img20.jpg before img100.jpg
  • Automatically include 32- or 64-bits mode in Help > Email.
  • Bug fixes:
    • Improve diagnostic on incorrect paste to Input Files panel.
    • Improve diagnostics if source image file cannot be read.
    • Improve diagnostic if selected source image for retouching is a different size from image being retouched.
    • Prompt for administrator or power user password when installing from a non-privileged account.

Improvements in T201106061305 (Beta)

  • Retouching: added control for screen brightness, allows improved visibility of halos in shadows (pro-only feature).
  • Batch mode: added option to allow saving output images to a designated folder without prefixing a source indication to their names.
  • Bug fixes:
    • Retouching now allows brushes as small as 1 pixel wide instead of 3 (radius=0 instead of radius=1).
    • Prevent a project from being saved into itself, which would otherwise result in a recursive copy situation.
    • Skip “trial” dialog on pro-only features if pro license is already installed.
    • Improved appearance of labels for pro-only features.

Improvements in T201105292045 (Beta)

  • Improved memory management: 64-bit versions now Set Automatically to a maximum of 3000 MB instead of 3/4 of physical memory.
  • StackShot interface: added “External trigger command” to allow software triggering of cameras that don't have StackShot-compatible shutters.

Improvements in T201105272030 (Beta)

  • First full release of StackShot controller and Stack New function.
  • Provide a separate trial period for each Pro function.
  • Additions to StackShot driver:
    • Added GUI controls that give better handling of the StackShot interface, especially for users who don't have StackShot.
    • For Macintosh, drivers are now automatically installed.

Improvements in T201104281035 (Beta)

  • Additions to StackShot driver
  • Extended range of movement to support new 200 mm rail.
  • Improved detection and diagnosis of communications errors.
  • Added option to log all communications with StackShot.
  • Upgraded to FTDI D2XX drivers level 1.0.4 for Macintosh (greatly improved reliability and responsiveness).
  • Plugged memory leak in StackShotHelper.
  • Bug fixes
    • Fixed problem of S-release being ignored if it occurred while an image was being prepared for retouching. This bug left the output window hung showing source until the “s” key was pressed and released again.
    • Fixed null pointer exception due to errant key/mouseclick directed to scale box when nothing was selected there.
    • Fixed bug causing output images to be read twice instead of just once when switching from one to another.
    • All special characters such as pound sign (#) in the installation directory paths.
    • Corrected appearance of pro-only features in Macintosh menu system.
    • Desktop appearance: changed shortcut icon to 48×48 for crisper appearance on Windows 7.

Improvements in T201103300050 (Beta)

  • Changes to main GUI of application:
    • Rearranged File menu to place most frequently used commands first.
    • Added Look & Feel option to control notification, on completion of saving an output image.
    • Professional-only features are now identified in the menu system and become gray for other license types when the trial period has expired. A Look & Feel option is provided to hide these features entirely instead of just turning them gray.
  • Additions to StackShot controller GUI
    • New “Back” and “Fwd” buttons work like the corresponding buttons on the StackShot controller box.
    • Fixed-position hotkeys “asdf” correspond to Back (a), Fwd (s), Set Start (d), Set End (f). Left and right arrow keys also work as hotkeys for Fwd and Back once either of those buttons has been pressed.
    • Maximum rail speed and ramp time appear as Device Settings in the configuration menu.
    • “Panic Stop” can be triggered by a button in the GUI, or by pressing spacebar at most times, or by pressing any button on the StackShot controller while the rail is in motion.
    • “High precision” mode is now enabled only when a sufficiently small step size is selected. (Threshold is set by user.)
    • Feedback is provided while a stack is being shot.
    • Step size, number of steps, and all configuration parameters are now retained between sessions.
  • Bug fix: avoid exception on extraneous event that touches image scale box

Improvements in T201103291930 (Beta)

  • Updated Java Runtime to version 1.6.0_24-b07.
  • Clarified licensing terms regarding Personal Edition and organizations.

Improvements in T201101291045 (Beta)

  • Bug fix: allow to acquire images with .JPEG extension during Stack New Images.

Improvements in T201012061455 (Beta)

  • Added interface to the StackShot automated focus rail and stepper motor controller (Professional Edition only).
  • Added “Stack New Images (PMax)” capability, to acquire and stack simultaneously (Professional Edition only).
  • Changed initialization of Stereo Preview to automatically load images based on the output image list selection(s).
  • Added look-and-feel option to automatically maximize on Stereo Preview and set back to normal on exit.
  • Added support for Instructional Lab Edition licenses.
  • Added ability to save a copy of DMap source images with unused pixels blanked out = made white. (Professional Edition only)
  • Added menu entry to set over/under layout.

Improvements in T201009091815 (Beta)

  • Now display any special license terms in the splash screen.
  • Bug fix: eliminated certain timing dependent exceptions in retouching due to unusual brush movements.

Improvements in T201008081620

  • Reworked retouching for improved performance on some computers that previously misbehaved when display hardware acceleration was set too high.
  • Added Preferences > Look & Feel option to control beeping when mouse or keyboard actions are ignored due to click-ahead prevention.
  • While retouching, “busy” status is now indicated by changing the brush color to gray in addition to enabling the operating system's “wait” cursor.
  • Error logs are now written automatically even if the application hangs so severely that it cannot be exited normally.
  • Bug fix: add warning dialog if application is closed while retouching is active.
  • Bug fix: Click-ahead while retouching is now prevented for keystrokes as well as mouse actions.
  • Bug fix: eliminated timing dependent exceptions in retouching due to navigating with shift-drag.
  • Bug fix: corrected obsolete version numbers in Help > About and Macintosh pinfo.

Improvements in T201004151335

  • Console logs are now saved on exit, as either LastNormalLog.txt or ErrorLog<timestamp>.txt in the application data directory.
  • Added extended diagnostics around strange exception in retouching (MaskMergePyramidsManager).
  • Added name and version of operating system to emails generated by Help > Email Zerene Systems.
  • Improved error checking for batch mode save images and projects.
  • Bug fix: extended trial “from first use” licenses can now be installed by users.
  • Bug fix: retouching brush now remains active if 'shift' is pressed when using output image as source.
  • Bug fix: “Expired Trial” watermarks are now removed immediately when a valid license is installed, rather than requiring exit and relaunch.

Improvements in T201002141655

  • Bug fix: remove a superfluous warning, introduced in T201002062230, that prevented unattended operation in batch mode if projects were being saved.
  • Bug fix: fix exception in retouching, if performed in a project that had been closed and re-opened with no further stacking operation and the output name template used the mininp/maxinp pattern.

Improvements in T201002062230

  • Bug fix: potentially catastrophic replication of files and/or deletion of existing project data if the “in specified directory” location for new projects was the same as a parent of the Save As directory for old projects.
  • Bug fix: avoid popping source window to front on each new source file selection.
  • Improved registration for some stacks requiring significant brightness correction.
  • Bug fix: add warning dialog if application is closed while an operation is in progress.
  • Bug fix: avoid null pointer exception when retouching with an expired trial licence.
  • Bug fix: in output image name templates, some instances of mininp with ”:charpos” were being ignored.

Improvements in T201001201425

  • Image display windows now automatically resize when the main application window is resized.
  • Two new Look & Feel preferences have been added. One of them is to automatically restore the default layout whenever a project is created or opened. The other is to automatically set display scale for the source and output windows so that full images are shown until you explicitly select another scale. These options are turned on by default. To get the old behavior, you must explicitly turn them off by unchecking the boxes in Options > Preferences > Look & Feel.
  • New projects are silently placed in the application default directory if they are specified to go with source images but that location cannot be written.
  • Improved diagnostics if there are unexpected problems in new project placement.
  • Bug fix: New Folder button now works in filechooser dialogs.
  • Bug fix: screen preview images are now updated correctly if preprocessing scale is changed after the stack has been processed.

Improvements in T200912272255 (Version 1.02)

  • Options > Preferences now allows to save and load preferences.
  • Batch scripts can now be saved and loaded.
  • When a directory or zip archive is loaded that contains a file named “ZereneBatch.xml”, that file is automatically executed as a batch script.
  • Command line arguments have been added to:
    • suppress the usual splash screen,
    • run with the GUI minimized,
    • force execution of a specified batch script,
    • automatically exit on completion of a batch script. These arguments and program-generated batch files provide a basic API (application programming interface) that allows other programs to launch and control Zerene Stacker, essentially using it to extend their own operations.
  • Order of processing (front to back, back to front) is now automatically determined to avoid “streaky edges”.
  • Image pre-sizing and pre-rotation can now be changed when a project is open.
  • Rules for generating output image names can now be specified by flexible templates for selecting and rearranging timestamp, method, source image names, output sequence numbers, and user-provided text.
  • When a project that contains multiple output images is opened, now none of them is selected automatically. This avoids unnecessary delay, particularly with large images.
  • Configuration is not saved if exit is forced while operation is in progress.
  • The amount of physical memory can now be provided by hand, even it was determined automatically. This allows manual correction of the rare case where an incorrect value is determined by the automatic process.
  • In batch mode, output image disposition can now be set independently for each task to be performed.
  • Tooltips have been added for Options > Preferences > Image Saving.
  • Clickable links are now supported in update notifications.
  • Priority of computational threads is reduced one more notch to improve responsiveness of interactive programs running at the same time.
  • Batch tweak: output images disposed as “Save in source folders”, will be placed with the first source image if the operation is specified as applying to ”%CurrentProject%”.
  • Bug fix: when retouching, pressing the shift key now does not clear the selection of an output image as source, unless the cursor is dragged.
  • Bug fix: properly handle scale change on new project in batch.
  • Bug fix: clear output window when project closed.
  • Bug fix: parameters were not always saved properly after “Reset to default”.
  • Bug fix: incorrect version was shown by Mac OS X system menu.

Improvements in T200911231310:

  • Image files can be read directly from .zip archives.
  • Drag-and-drop now accepts directories and .zip archives. For ordinary directories, all images in the directory itself are added, but not any in subdirectories. For zip archives, images one level down are added also. (This convention means that the same files are accessed in an ordinary directory of images as when the .zip archive is created by Windows using “Send <folder> to Compressed (zipped) Folder”.)
  • More robust memory management: allows working with larger images near the limits of available memory.
  • Updated to the most recent version of Sun JVM.
  • Increased default alignment limits to 20% to allow proper handling of more cases especially for handheld stacks.
  • Added a “Reset to Default” button for alignment limits.
  • UI tweak: “Abort” button changed to say “Cancel”.
  • Bug fix: ignore “non-breaking space” injected into license keys during certain email transfers.
  • Bug fix: avoid hang in certain rare cases where alignment limits are exceeded.
  • Bug fix: on Windows 7, filechooser icons are no longer missing.
  • Bug fix: on Windows 7, the Abort button now looks like a button.
  • Bug fix: in batch mode, properly diagnose source directories that cannot be read or that do not contain at least two image files.
  • Bug fix: remove confusing entry from list of zoom factors.

T200909262115 was the first release of version 1.0, marking the end of the public beta period.

Improvements included:

  • Change default license key to be 30-days-from-first-use free trial.
  • Automatically stop stereo previewing when project is closed.
  • On Macintosh, give proper instructions if browser cannot be opened to download a new version.
  • Bug fix: when retouching, completely reset edit mask on source file changes to avoid accumulating brush effects on nearby edits.
  • Bug fix: properly handle non-ASCII characters in license keys.

Improvements in T200909130840:

  • A new option has been added for handling TIFF files: Options > Preferences > Preprocessing > Use External TIFF Reader. This option is now used by default on Intel Macintosh computers, where it fixes the problem that many kinds of TIFF files used to be very slow to read (minutes per image). Well-behaved TIFF files will read somewhat more slowly with this option selected, so if you were previously getting good results with TIFF on Macintosh, you may prefer to de-select the new option.
  • Gray-scale images are now supported.
  • Added time-from-start stamps to each line of console log.
  • Batch mode is included with Student licenses.
  • Added Cancel option if new project cannot be created where specified by Options > Preferences.
  • When selecting image files using the mousewheel, each selection event is now shown immediately instead of only when input stops.
  • Stereo/rocking selection is now turned off when Zerene Stacker is launched. It is also turned off in saved projects.
  • “Paste from clipboard” button is provided in registration dialog.
  • License key validation can now handle lines being merged due to email reformatting.
  • Bug fix: avoid rare silent hang in brightness correction.
  • Bug fix: correctly handle pre-rotation in filechooser preview images.
  • Bug fix: in batch mode, “Save in project folders” now creates the SavedImages directory if required.
  • Bug fix: in batch mode, folders of image files can now contain subfolders and Zerene Stacker projects.
  • Bug fix: menu entries for retouching and stereo operations are now interlocked to avoid conflicting selections.
  • Bug fix: File > Close Project now clears output window in all cases.
  • Bug fix: Mac version now does not truncate leading digits of zoom factor.
  • Bug fix: removed spurious sequence number from the names of retouched image files.

Improvements in T200908150945:

  • Run heavy computations at reduced priority, for better responsiveness on multi-function systems.
  • Much faster retouching brush with large images.
  • Changed appearance of “unable to check for updates” popup dialog from error to informational.
  • Updated license terms to cover purchased licenses.
  • Bug fix: avoid bogus popup diagnostics caused by “s” and ” ” getting directed to scale boxes during retouching.
  • Bug fix: changes to presizing were sometimes not honored until next program execution.

Improvements in T200907311550:

  • Added menu entry to run both PMax and DMap in a single command.
  • Multiple output images can now be written to image files in a single step.
  • Stacks can now be synthetically skewed by a few degrees before stacking. This can be used to generate stereo pairs from a single stack, or to create a sequence of frames to make a “rocking” animation, or both.
  • Added stereo preview tool to pick best two frames from a skew sequence.
  • Added “Make Stereo Pair(s)” tool to construct side-by-side stereo pair images.
  • Images can now be pre-rotated as well as pre-sized. This is particularly useful when generating stereo pairs from images shot in vertical format.
  • Improved speed when not pre-sizing.
  • Reduced memory requirement when aligning and stacking in one pass.
  • Reduced memory requirement even farther when aligning and stacking as separate operations.
  • Improved reliability when short on memory.
  • Produce diagnostic popup when drag-and-drop fails to add a file because the file is not an acceptable image type.
  • Report detailed diagnostic when drag-and-drop fails to add a file because of some unexpected problem.
  • Convenience tweak: automatically select the output window when it is popped to front.
  • Changed filechooser labeling to clarify that “raw” image files cannot be handled directly.
  • Progress bar and hourglass now shows when adding files.
  • Drag-and-drop to input files list now works on Linux and Macintosh.
  • Options > Preferences > Memory Usage now works on Linux.
  • Added name of licensed user to title bar.
  • Linux 32-bit and 64-bit for Intel and compatible processors are now standard build versions.
  • Bug fix: physical memory size is now detected on Mac OS X 10.4.
  • Bug fix: in Macintosh native look-and-feel, files that are not acceptable image types can no longer be selected for additions.
  • Bug fix: in Preferences > Color Management, changes to the profile selection were sometimes not saved.
  • Bug fix: Linux version now accepts drag-and-drop.

Improvements in T200907112235 include:

  • The user can now specify pre-scaling of images before stacking. See Options > Preferences > Preprocessing.
  • Options > Preferences > Memory Usage is now used to specify memory allocation. This replaces manual editing of the file 'zerenstk.ini' (Windows) or Info.plist (Macintosh), as required in previous versions.
  • Macintosh version is extended to run in 64-bit mode on systems that support 64-bit Java. (This includes Intel Core 2 Duo and higher, but not Intel Core Duo and lower.)
  • Placement of the zerenstk.cfg configuration file has been modified so that program settings are specific to the individual user and will be retained across future updates. On Windows, it is now consistently placed in %appdata%\ZereneStacker, even if the program is installed to someplace other than Program Files. For this update only, advanced Windows users who installed Zerene Stacker in a writeable directory may wish to copy or move zerenstk.cfg from that directory into the new location, %appdata%\ZereneStacker\zerenstk.cfg On Macintosh, it now resides in the user's Library/Preferences directory. For this update only, advanced Macintosh users may want to copy or move zerenstk.cfg from their current Zerene Stacker application bundle: ZereneStacker.app/Contents/Resources/Java/zerenstk.cfg into the new location: ~/Library/Preferences/ZereneStacker/zerenstk.cfg
  • On Windows, the launcher is now much more robust. It now automatically falls back to “safe mode” if the current parameters do not give a successful launch. This prevents undiagnosed failures when more memory is specified than can be obtained.
  • On Windows, an explicit ”(Safe Mode)” icon is now provided. This icon launches the program with a very conservative memory allocation. It also ignores any window location and size that may have been left over from a previous execution. This icon provides a simple method to recover from unusual conditions such as memory settings or changes in monitor placement that would otherwise prevent launching or would place the Zerene Stacker window where it could not be seen.
  • Added explanatory tooltip to “Show as adjusted” checkbox.
  • Added registration dialog for entering a license key.
  • Expired versions now fall back to “expired trial” mode rather than refusing to run.
  • Changed the default directory for unsaved new projects to be within java.io.tmpdir, which is the standard temporary directory for each computer. On Windows, this is typically “C:\Documents and Settings\username\Local Settings\Temp\ZereneStacker”. On Macintosh, it is typically ”/private/tmp/ZereneStacker”.
  • Replaced the icon with a more colorful version. (The current icon is the distinctive wing pattern of Zerene eurydice, the California Dogface butterfly.)
  • Added diagnostic if saving over an old project will cause any files not created by Zerene Stacker to be removed.
  • Bug fix: on Macintosh, main menu bar would sometimes disappear and not return, when smaller dialog windows were opened and closed.
  • Bug fix: projects could not be saved sometimes if this would require copying files from one device to another.
  • Bug fix: scrollbars would not appear sometimes until scale factor was changed.
  • Bug fix: encountering too many errors would make it impossible to close the error notification window.

Improvements in T200905191912

  • Added mouse and key logging in the retouching manager, controlled by RetouchingManager.LogEvents=true in the zerenstk.cfg file.

Improvements in T200905131155

  • Versions are now available for the following platforms:
    • Windows 32-bit
    • Windows 64-bit (using the native 64-bit JVM)
    • Mac OS X Tiger (PowerPC and Intel)
    • Mac OS X Leopard (PowerPC and Intel)
  • A user interface is now provided to show the amount of memory allocated for Zerene Stacker. However, to *adjust* this setting still requires manual editing of a configuration file, outside of the Zerene Stacker interface. Removing the manual editing step is a high priority for the next release.
  • Images too large to be processed are now diagnosed, and can be automatically pre-sized (shrunk) to process in available memory.
  • Insufficient physical memory to run efficiently is now diagnosed.
  • A user interface is provided to specify or override the amount of physical RAM available on the computer, if it cannot be determined automatically.
  • Bug fix: when the DMap contrast threshold dialog is shown, the main window is also made visible if necessary. (Previously the main window would remain invisible if it happened to be minimized.)
  • Bug fix: on Macintosh, command-Q and Quit from the Applications menu are now handled correctly.

Improvements in T200904161830

  • Retouching now allows certain keystrokes to be used as an alternative to mousewheel rotation. To make the brush larger or smaller, you can use ”[” or ”]”. To navigate through the list of input files, you can hold down Shift and use up- or down-arrow.
  • There is a new Look-and-Feel option to control whether preview images and certain controls are included in the file chooser windows for adding and saving images, or are presented as separate windows. This option is primarily for cross-platform compatibility, which is being prepared for release soon. The defaults adjust to the platform type so that file choosers present a natural appearance on both Windows and Macintosh.
  • Automatically adapts to memory size of the computer. This avoids excess paging when running in smaller computers such as 1 GB. It also allows processing larger images than the previous version, on 2 GB machines.
  • Alignment is more robust when working with small images.
  • Compatibility: code base now compiles and runs against Java 5 (for Mac OS X Tiger).
  • Bug fix: previous alignments are now discarded when an input image is removed.
  • Bug fix: removed one cause of a red exception and hang while retouching.

Build T200904032045 was the first public beta release.

stacker/docs/modificationhistory · Last modified: 2017/11/22 05:26
Copyright 2009-2017, Zerene Systems LLC, all rights reserved.