Zerene Stacker

Working With Lightroom

Lightroom Plugin

Zerene Stacker now has a plug-in capability that makes it simple to get images from Lightroom into Zerene Stacker and back to Lightroom again. This "Pro-only" feature was introduced at Build T201401030945_beta and is available in the current full release at http://zerenesystems.com/cms/stacker/softwaredownloads. It should work with any version of Lightroom at version 3.0 or above.

To install the plugin, just run Zerene Stacker, then go to Options > Plugins… > Lightroom and select where you want the plugin to be installed. By default the plugin goes into the standard Lightroom Modules folder, so it will be automatically available on the next launch of Lightroom. If you choose to put the plugin somewhere else, then you'll have to manually install it using File > Plug-in Manager in Lightroom.

Once the plugin is installed in Lightroom, you'll see several new Lightroom menu entries. Probably the most convenient is in the context menu under “Export” when you right-click on a selected image. Other entries are at File > Export… and at File > Plug-in Extras. To use the plugin, just select the images you want to have stacked, then select any of those Export menu entries. The selected images will be automatically passed to Zerene Stacker, so that a few seconds later you'll see an ordinary Zerene Stacker window with your Lightroom images loaded into it. In Zerene Stacker, proceed as usual to stack, retouch, etc. When you want to push output images back into Lightroom, just use File > Save Output Image(s) in Zerene Stacker, then back in Lightroom, do Library > Synchronize Folder. If the Synchronize Folder entry is gray, it's probably because you're looking at some filtered view like Previous Import. In that case, hover over one of the selected images that you stacked and do a right-click (or Ctrl-click on Mac) to get a context menu popup. In that popup menu, select “Go to Folder in Library”. Then do the Library > Synchronize Folder in the main menu bar.

Behind the user interface, the Lightroom plugin works by having Lightroom produce a temporary copy of each selected image, in a format that can be read by Zerene Stacker. Images in raw format are converted automatically. Zerene Stacker works on the temporary files, then automatically deletes them when it terminates. If you do a File > Save Project, then copies of the image files are retained in the Zerene Stacker project directory for further use such as retouching.

The default format for Export to Zerene Stacker is 16-bit TIFF in sRGB color profile. This can be changed during the export process if you go through File > Export… or right-click > Export > Export…

Explicit Export/Import

Prior to build T201401030945, Zerene Stacker did not have a “plugin” that integrated tightly with Lightroom. Instead, Zerene Stacker ran as a separate program alongside Lightroom, with files being transferred back and forth by explicitly exporting and importing files. The following sections of this page describe this older method.

There are two separate issues:
1) how to get source images from Lightroom into Zerene Stacker, and
2) how to get output images from Zerene Stacker back into Lightroom.

Usually people have more trouble with the second part, but the instructions will make more sense if we take them in order.

Getting source files from Lightroom into Zerene Stacker

There are three common approaches for getting source images from Lightroom into Zerene Stacker.

The first approach, which works on all types of computers and for any number of images, is to explicitly export from Lightroom, then get those files into Zerene Stacker by either drag-and-drop or File > Add File(s). This is the most broadly applicable approach.

The second approach, which works only on Windows computers and only for a limited number of images, is to set up Zerene Stacker as an External Editor for Lightroom. Once that's done, you can use Lightroom's “Edit In” function to implicitly export files and pass them to Zerene. This is more complicated to set up but it's more convenient for long term use.

To do the setup, go to Lightroom's Edit > Preferences > External Editing tab. There you select zerenstk.exe as the application (typically by pressing the Choose button and selecting it from directory C:\Program Files\ZereneStacker). Define what file format you want to stack from, save the settings as a preset named “Zerene Stacker”, and click OK to close the Preferences window.

Then to invoke Zerene Stacker, you use Grid View in Lightroom to select the images you want to stack, hover over any one of them, right-click, hover over Edit In (in the popup menu), then select the “Zerene Stacker” preset.

If the files are already in a format compatible with the preset, then you'll be offered the option to “Edit Original”. Otherwise you'll be offered only the option to “Edit a Copy” (with or without Lightroom Adjustments). Select an appropriate option and click the Edit button.

A short time later, the Zerene Stacker interface will pop up, with the source files loaded. Process the stack, save the output file, exit from Zerene Stacker, and do a Lightroom import as described below.

Note: When using this method there are limits on how many images can be in a stack. Under the covers, this is due to a Windows limitation on command line length. Because of the command line limit, the exact limit on number of images depends on how many characters are in the path names. Longer paths will allow fewer files; shorter paths allow more. In our testing, the limit was about 30 images using path names like “F:\T1iCameraImages\100CANON\IMG_6572.JPG”.

If you try to do more than the limit, then Lightroom launches multiple copies of Zerene Stacker with each copy getting only some of the images. Obviously that's not going to do what you want.

So, if you're going to be processing deep stacks, you'll need to run Zerene Stacker as a completely separate program. In this case you may need to explicitly export images from Lightroom, for example if your images are stored in Lightroom in raw format which ZS does not handle.

The third approach, which works only on Macintosh computers and only for images that are already in JPEG or TIFF formats, is to drag-and-drop source images directly from Lightroom into a running copy of Zerene Stacker.

Using this method, there are several fine points to watch out for:
1. Make sure Zerene was the last active app. For example if you launch Zerene, switch to finder, and then to Lightroom, drag and drop may not work. But if you switch from Zerene directly to Lightroom, no problem.
2. Be sure to drop onto the text ”(Drop files here to begin)” (i.e. not in the empty space below).
3. When selecting images and initiating the drag-and-drop in Lightroom, be sure to press the mouse button while hovering over the thumbnail proper, not the frame that surrounds it. Pressing while hovering over the frame will simply select that one image, not set up to drag-and-drop the multiple images that are selected.

Getting output images from Zerene Stacker back into Lightroom

To get an output image from Zerene Stacker back into Lightroom, you have to explicitly save it out of Zerene Stacker, then manually import it back into Lightroom.

In detail…

After Zerene Stacker is done stacking, you use its File > Save Output Image(s) function to save the file as either TIFF or JPEG in some specified folder. By default, it will go back into the same folder that the source images came from, but you can put it anywhere by selecting a folder before pushing the Save button.

Then, back in Lightroom's Navigator window, do a right-click on the Lightroom folder where you want the image to appear, and select “Import to this Folder…”. In the Import window, select the folder where you had Zerene Stacker place its output. Be sure that “Don't Import Suspected Duplicates” is selected, confirm that the new image is selected, and click the Import button. That will cause Lightroom to add the output image into Lightroom's catalog so that you'll be able to deal with it normally.

The explicit Import in Lightroom is needed to make Lightroom know about a new image file. You might think that Lightroom would automatically notice when an image file appears in a Windows or Mac OS X folder that stores the images in a Lightroom folder. But it doesn't. You have to tell it to notice by doing the Import.

Problems? Let us help!

In case of difficulties, please contact support@zerenesystems.com so that we can help out and improve our product.

stacker/docs/workingwithlightroom · Last modified: 2015/11/24 22:37
Copyright 2009-2017, Zerene Systems LLC, all rights reserved.