Zerene Stacker

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
stacker:docs:faqlist [2020/06/29 19:07]
rjlittlefield Part of my subject looks transparent. What can I do?
stacker:docs:faqlist [2021/06/29 16:19] (current)
rjlittlefield [How can I update the program?]
Line 33: Line 33:
   * [[#​is_there_some_way_to_save_exif_and_other_metadata|Is there some way to save EXIF and other metadata?]]   * [[#​is_there_some_way_to_save_exif_and_other_metadata|Is there some way to save EXIF and other metadata?]]
   * [[#​why_do_my_output_images_say_they_re_only_72_pixels_per_inch|Why do my output images say they'​re only 72 pixels per inch?]]   * [[#​why_do_my_output_images_say_they_re_only_72_pixels_per_inch|Why do my output images say they'​re only 72 pixels per inch?]]
 +  * [[#​what_exactly_is_a_project|What exactly is a project?]]
  
 **Shooting Stacks** **Shooting Stacks**
Line 61: Line 62:
   * [[#​why_did_the_software_reverse_the_order_of_my_images|Why did the software reverse the order of my images?]]   * [[#​why_did_the_software_reverse_the_order_of_my_images|Why did the software reverse the order of my images?]]
   * [[#​can_i_directly_control_the_order_that_images_are_processed|Can I directly control the order that images are processed?​]]   * [[#​can_i_directly_control_the_order_that_images_are_processed|Can I directly control the order that images are processed?​]]
 +  * [[#​my_stack_got_shot_out_of_order_what_can_i_do|My stack got shot out of order. ​ What can I do?]]
   * [[#​why_do_my_saved_output_images_look_washed_out|Why do my saved output images look washed out?]]   * [[#​why_do_my_saved_output_images_look_washed_out|Why do my saved output images look washed out?]]
   * [[#​what_does_retain_extended_dynamic_range_mean|What does "​Retain extended dynamic range" mean?]]   * [[#​what_does_retain_extended_dynamic_range_mean|What does "​Retain extended dynamic range" mean?]]
Line 72: Line 74:
  
   * [[#​what_are_some_tips_for_fast_retouching|What are some tips for fast retouching?​]]   * [[#​what_are_some_tips_for_fast_retouching|What are some tips for fast retouching?​]]
-  * [[#​what_are_the_different_brush_types_for_retouching?|What are the different brush types for retouching?​]]+  * [[#​what_are_the_different_brush_types_for_retouching|What are the different brush types for retouching?]] 
 +  * [[#​sometimes_i_see_noise_getting_added_when_I_retouch_why_is_that|Sometimes I see noise getting added when I retouch. ​ Why is that?]] 
 +  * [[#​i_did_not_save_a_project_can_i_retouch_anyway|I did not save a project. Can I retouch anyway?]]
  
 **Miscellaneous** **Miscellaneous**
Line 78: Line 82:
   * [[#​do_you_have_a_user_forum|Do you have a user forum?]]   * [[#​do_you_have_a_user_forum|Do you have a user forum?]]
   * [[#​how_does_zerene_stacker_work_with_lightroom|How does Zerene Stacker work with Lightroom?​]]   * [[#​how_does_zerene_stacker_work_with_lightroom|How does Zerene Stacker work with Lightroom?​]]
-  * [[##​are_there_any_keyboard_shortcuts|Are there any keyboard shortcuts?​]]+  * [[#​are_there_any_keyboard_shortcuts|Are there any keyboard shortcuts?​]]
   * [[#​is_there_some_way_to_turn_off_the_welcome_screen|Is there some way to turn off the welcome screen?]]   * [[#​is_there_some_way_to_turn_off_the_welcome_screen|Is there some way to turn off the welcome screen?]]
   * [[#​is_there_some_way_to_control_those_output_names|Is there some way to control those output names?]]   * [[#​is_there_some_way_to_control_those_output_names|Is there some way to control those output names?]]
Line 196: Line 200:
 On Windows, installing the new version will automatically replace the old version. On Windows, installing the new version will automatically replace the old version.
  
-On Macintosh and Linux, you will have to manually move the old version to trash, and move or rename the new version to replace it.  Otherwise both versions will continue to be available, and you will run whichever one you happen to click on.  On Mac, when trashing out the old version, do __**NOT**__ allow any third party uninstaller or cleanup applications like "​AppCleaner"​ to run.  In their enthusiasm to eliminate files that they think are not used, they'​re likely to also delete files you really do need, like your license key and Zerene Stacker configuration files.+On Macintosh and Linux, you will have to manually move the old version to trash, and move or rename the new version to replace it.  Otherwise both versions will continue to be available, and you will run whichever one you happen to click on.  If you have created a Dock icon for the old version, you should remove that also, and re-create it for the new version.  On Mac, when trashing out the old version, do __**NOT**__ allow any third party uninstaller or cleanup applications like "​AppCleaner"​ to run.  In their enthusiasm to eliminate files that they think are not used, they'​re likely to also delete files you really do need, like your license key and Zerene Stacker configuration files.
  
  
Line 274: Line 278:
 The troublesome output images don't actually say 72 ppi.  What's happening is that Zerene Stacker has produced an output image that does not have a ppi specification at all, and whatever tool you're using to look at the image has assigned its own default interpretation of "72 ppi"​. ​ Ppi is not meaningful for screen images, and for prints ppi is implied by the combination of print size and pixel count. ​ If you really do need some particular setting for ppi inside the image file because that's how a requirement happens to be specified, then just pull the file into Photoshop, do an Image > Image Size... with the checkmark removed on "​Resample Image",​ then save the result to a new file. The troublesome output images don't actually say 72 ppi.  What's happening is that Zerene Stacker has produced an output image that does not have a ppi specification at all, and whatever tool you're using to look at the image has assigned its own default interpretation of "72 ppi"​. ​ Ppi is not meaningful for screen images, and for prints ppi is implied by the combination of print size and pixel count. ​ If you really do need some particular setting for ppi inside the image file because that's how a requirement happens to be specified, then just pull the file into Photoshop, do an Image > Image Size... with the checkmark removed on "​Resample Image",​ then save the result to a new file.
  
-There is an option to preserve the ppi setting, by selecting Options > Preferences > Image Saving > "Copy metadata from source images to saved output images",​ before doing File > Save Output Image(s). ​ This [[stacker:​docs:​faqlist?&#​i_see_some_menu_items_labeled_pro_what_does_that_mean|Pro-only]] option will also save all other EXIF metadata such as camera & lens type, exposure settings, GPS location, and so on.  Note that "Copy metadata..."​ is automatically selected by default when you are running the Lightroom plug-in, so if you're running the trial version with default settings, you may notice a difference between going through Lightroom and launching Zerene Stacker separately.+There is an option to preserve the ppi setting, by selecting Options > Preferences > Image Saving > "Copy metadata from source images to saved output images",​ before doing File > Save Output Image(s). ​ This [[stacker:​docs:​faqlist?&#​i_see_some_menu_items_labeled_pro_what_does_that_mean|Pro-only]] option will also save all other EXIF metadata such as camera & lens type, exposure settings, GPS location, and so on.  Note that "Copy metadata..."​ is automatically ​selected by default if you are using a Prosumer Edition or Professional Edition license key.  It is also selected by default when you are running the Lightroom plug-in, so if you're running the trial version with default settings, you may notice a difference between going through Lightroom and launching Zerene Stacker separately. 
 + 
 +===== What exactly is a "​project"?​ ===== 
 + 
 +In the computer’s file system, each Zerene Stacker project consists of a folder that contains a "​.zsj"​ file and several subfolders. ​ The .zsj file is the master description for the project. ​ You can look inside it with any text editor. ​ Typical subfolders include "​generatedimages",​ which contains output images in "​.zsy"​ format; "​previewimages",​ which contains cached screen preview images as low quality "​.jpg";​ "​AdjustedSourceImages"​ if Save Adjusted Images has been used; and so on. 
 + 
 +When using File > Open Project inside Zerene Stacker, the project may appear in a couple of different ways.  Usually it appears as an ordinary folder, so to open the project you must navigate inside the project folder, select the .zsj file, and open that.  However, if Options > Preferences > Look & Feel is set to //not// use "​system native File Choosers",​ then File > Open Project will show the project folder as a single "​yellow smiling dog" icon that can be selected and opened without navigating inside it. 
 ===== Does Zerene Stacker help me to shoot a stack? ===== ===== Does Zerene Stacker help me to shoot a stack? =====
  
Line 294: Line 305:
  
 One exception occurs if your subject is liable to move away while you're shooting. ​ In that case you should start at whichever end you consider most important, so that if the subject does leave you may still have something useful to work with. One exception occurs if your subject is liable to move away while you're shooting. ​ In that case you should start at whichever end you consider most important, so that if the subject does leave you may still have something useful to work with.
 +
 ===== Do I need a focus rail? ===== ===== Do I need a focus rail? =====
  
Line 342: Line 354:
  
 Edge streaks can also be caused by forcing a stack to be processed starting at the "​wide"​ end, meaning whichever end of the stack has the widest field of view.  In this case the streaks are likely to appear on all four edges, and may extend from the edge of the image to the edge of the narrowest field of view.  With standard settings, Zerene Stacker automatically determines which is the narrow end of the stack and starts there, which completely prevents edge streaks with a well aligned stack. ​ However, it can be forced to start at either end by de-selecting Options > Preferences > "​Automatic order"​. ​ Normally we recommend to leave "​Automatic order" selected, and set things up when the stack is shot so that everything you care about is contained even within the narrowest frame. ​ See the tutorial [[http://​zerenesystems.com/​cms/​stacker/​docs/​tutorials/​tutorial002#​summaryuse_either_method_but_be_sure_to_check_framing|HERE]] for more information on that point. Edge streaks can also be caused by forcing a stack to be processed starting at the "​wide"​ end, meaning whichever end of the stack has the widest field of view.  In this case the streaks are likely to appear on all four edges, and may extend from the edge of the image to the edge of the narrowest field of view.  With standard settings, Zerene Stacker automatically determines which is the narrow end of the stack and starts there, which completely prevents edge streaks with a well aligned stack. ​ However, it can be forced to start at either end by de-selecting Options > Preferences > "​Automatic order"​. ​ Normally we recommend to leave "​Automatic order" selected, and set things up when the stack is shot so that everything you care about is contained even within the narrowest frame. ​ See the tutorial [[http://​zerenesystems.com/​cms/​stacker/​docs/​tutorials/​tutorial002#​summaryuse_either_method_but_be_sure_to_check_framing|HERE]] for more information on that point.
 +
 +In recent versions of Zerene Stacker, edge streaks can be avoided by checking the box at Options > Preferences > Preprocessing > "Use dust & defects mask", and also checking the box under that to "Avoid edge streaks"​. ​ (For this use, you do not need to provide a dust & defects mask "from file"​.) ​ However, while this option will prevent the introduction of streaks, that region of the result image may still be degraded if the subject has details that were never captured in sharp focus due to the shift in framing. ​ It is better to avoid the shift in framing while the stack is being shot, if possible.
  
 ===== My output images have worm trails! ​ Why is that? ===== ===== My output images have worm trails! ​ Why is that? =====
Line 349: Line 363:
 If you carefully check your source images, you will find that in each of them there are a few individual spots, one spot for each trail in your output. If you carefully check your source images, you will find that in each of them there are a few individual spots, one spot for each trail in your output.
  
-Those spots will occur at exactly the same pixel coordinates in each source image.+Those spots typically ​occur at exactly the same pixel coordinates in each source image. ​ (In rare cases individual spots may move //​slightly//​ as focus is changed, due to axial shift of the lens's exit pupil.)
  
 The reason that trails appear during the stacking process is this:  Due to magnification changes, jitter, or systematic drift in your focus stepping setup, the subject moves slightly left/​right/​up/​down in each frame. ​ Essentially the subject is moving around with respect to the spots. ​ In order to make a clean rendering, the focus stacking process must correct for the subject movement, so the subject stays in the same place for each frame. ​ But then the spots appear to move around with respect to the subject. ​ To the focus stacking algorithms, the spots look just like sharp detail that should be retained, and so in the final image you see each spot in every position that it ever occupied with respect to the subject. ​ In combination with the human eye's great ability to pick out linear structures, this causes each spot to become a collection of spots that looks like a straight line, a wiggly trail, or something in between, depending on exactly how the jitter and drift behaved in the first place. The reason that trails appear during the stacking process is this:  Due to magnification changes, jitter, or systematic drift in your focus stepping setup, the subject moves slightly left/​right/​up/​down in each frame. ​ Essentially the subject is moving around with respect to the spots. ​ In order to make a clean rendering, the focus stacking process must correct for the subject movement, so the subject stays in the same place for each frame. ​ But then the spots appear to move around with respect to the subject. ​ To the focus stacking algorithms, the spots look just like sharp detail that should be retained, and so in the final image you see each spot in every position that it ever occupied with respect to the subject. ​ In combination with the human eye's great ability to pick out linear structures, this causes each spot to become a collection of spots that looks like a straight line, a wiggly trail, or something in between, depending on exactly how the jitter and drift behaved in the first place.
Line 357: Line 371:
 The best cure for these problems is to prevent them in the first place. ​ Fixing the problem after the stack has been shot inevitably means guessing about what the pixel values should have been, that were hidden by the spots. ​ So, it's best to clean your sensor and keep it that way.  Warm pixels get worse with long exposures and higher temperatures,​ so the best way to avoid them is to use short exposures by adding light, typically flash. ​ It also helps to avoid Live View mode during actual shooting, if possible, because continuous use of the sensor during Live View causes the sensor to get warmer. The best cure for these problems is to prevent them in the first place. ​ Fixing the problem after the stack has been shot inevitably means guessing about what the pixel values should have been, that were hidden by the spots. ​ So, it's best to clean your sensor and keep it that way.  Warm pixels get worse with long exposures and higher temperatures,​ so the best way to avoid them is to use short exposures by adding light, typically flash. ​ It also helps to avoid Live View mode during actual shooting, if possible, because continuous use of the sensor during Live View causes the sensor to get warmer.
  
-If you cannot avoid dust or warm pixels in the first place, then the second-best approach is to remove them before stacking, using some technique equivalent to batch mode dust removal.  ​This can be done using tools such as Lightroom or Photoshop. ​ You can find a lot of information about this by searching the internet for words like "​remove dust from multiple pictures"​. ​ Alternatively,​ it often works great to paint over the trails by retouching, either inside Zerene Stacker using Edit > Retouching, or outside Zerene Stacker using something like Photoshop'​s healing brush or clone tool.+If you cannot avoid dust or warm pixels in the first place, then the second-best approach is to remove them before stacking, using some technique equivalent to batch mode dust removal.  ​ 
 + 
 +In recent versions of Zerene Stacker, dust trails ​can be avoided by preparing a mask image that shows Zerene Stacker where spots should be removed, then checking the box at Options > Preferences > Preprocessing > “Use dust & defects mask”, and providing the name and folder path of the mask image. ​ The mask image must be the same size and orientation as the source images, with black dots on a pure white background. ​ For an extended discussion of how to create and use a dust and defects mask, see [[https://​www.photomacrography.net/​forum/​viewtopic.php?​t=41343]] .  Note that in Zerene Stacker, the dust & defects mask is a [[:​stacker:​docs:​faqlist#​i_see_some_menu_items_labeled_pro_what_does_that_mean|Pro-only feature]]. ​  
 + 
 +Dust and defect removal can also be done   
 +using tools such as Lightroom or Photoshop. ​ You can find a lot of information about this by searching the internet for words like "​remove dust from multiple pictures"​. ​ Alternatively,​ it often works great to paint over the trails by retouching, either inside Zerene Stacker using Edit > Retouching, or outside Zerene Stacker using something like Photoshop'​s healing brush or clone tool.
  
 ===== My colors changed a little. ​ Why is that? ===== ===== My colors changed a little. ​ Why is that? =====
Line 394: Line 413:
 However, in many cases one or more of those issues is ruled out by hardware when the stack is shot.  If you're using a focus rail or a microscope, then it's unlikely that there'​s any rotation to deal with.  If you're using continuous illumination instead of flash, then it's probably quite consistent from frame to frame. ​ In some microscopy work, __none__ of these issues are important. However, in many cases one or more of those issues is ruled out by hardware when the stack is shot.  If you're using a focus rail or a microscope, then it's unlikely that there'​s any rotation to deal with.  If you're using continuous illumination instead of flash, then it's probably quite consistent from frame to frame. ​ In some microscopy work, __none__ of these issues are important.
  
-The basic guideline is to turn off any alignment option that you don't need.  That will make the alignment process go faster. ​ In some cases, particularly at high magnification such as through a microscope, turning off unnecessary options will also give a better result image. ​ This issue is discussed in a lot more detail in the forum thread at [[http://​www.photomacrography.net/​forum/​viewtopic.php?​p=79878#​79878]].+The basic guideline is to turn off any alignment option that you don't need.  That will make the alignment process go faster. ​ In some cases, particularly at high magnification such as through a microscope, turning off unnecessary options will also give a better result image. ​ This issue is discussed in a lot more detail in the forum thread at [[https://​www.photomacrography.net/​forum/​viewtopic.php?​p=79878#​79878]].
  
 ===== What do the percentages mean for Alignment parameters? ===== ===== What do the percentages mean for Alignment parameters? =====
Line 408: Line 427:
 The two methods complement each other. Some types of subjects look good when they are processed automatically by PMax, but not by DMap. Other subjects are just the opposite. For particularly challenging subjects like bugs and flowers shot through microscope objectives, neither method is ideal by itself. In that case the best results are obtained by using human judgment and the retouching tool to combine the best aspects of both algorithms. The two methods complement each other. Some types of subjects look good when they are processed automatically by PMax, but not by DMap. Other subjects are just the opposite. For particularly challenging subjects like bugs and flowers shot through microscope objectives, neither method is ideal by itself. In that case the best results are obtained by using human judgment and the retouching tool to combine the best aspects of both algorithms.
  
-For further discussion of these issues, see "DMap versus PMax" on the [[http://​zerenesystems.com/​cms/​stacker/​docs/​howtouseit|Zerene Stacker: How To Use It]] page.+For further discussion of these issues, see "DMap versus PMax" on the [[http://​zerenesystems.com/​cms/​stacker/​docs/​howtouseit|Zerene Stacker: How To Use It]] page, and also the "How To Use DMap" and video retouching tutorials, all linked on the main [[https://​zerenesystems.com/​cms/​stacker/​docs/​tutorials/​tutorialsindex|Tutorials index page]].
  
 ===== How should I choose those DMap Settings? ===== ===== How should I choose those DMap Settings? =====
Line 474: Line 493:
  
 By removing the checkmark on "​Automatic order" and adding files one at a time, you can set exactly any order that you want.  By removing the checkmark on "​Automatic order" and adding files one at a time, you can set exactly any order that you want. 
 +
 +===== My stack got shot out of order. ​ What can I do? =====
 +
 +In many cases there'​s a simple trick that handles this problem.
 +
 +The trick is this: after you've processed the stack at least once, so that all the images have been aligned against each other, then do a File > "​Re-order input files" > "Sort by Scale"​. If the files were originally not in strict focus order, chances are they will be in strict focus order after the sort is done. Then you can do another Stack operation to take advantage of the improved ordering. In especially difficult cases, it may help to do the steps of stacking and "Sort by Scale" a couple of times, to give the software the best opportunity to accurately calculate scale.
 +
 +To understand how the trick works, first note that with most optics, the image changes size along with focus. Depending on the lens, the image might get smaller or larger as focus moves back, but it's probably only going to do one of those, and it will do it consistently and by a large enough amount to be reliably determined by the computational alignment process. Fortunately,​ the alignment process can usually determine scale accurately even when the images are initially out of order, and then sorting by the recovered scale puts them back into order again.
 +
 +The nice thing about "Sort by Scale" is that it doesn'​t require much thinking or mouse-clicking. The alternative is to figure out by eye what the focus order was, then manually add files into the stacking software one at a time or in appropriate groups to get the correct ordering. ​ Alternatively,​ some people rename their image files so as to be in focus order when sorted by name.
  
 ===== Why do my saved output images look washed out? ===== ===== Why do my saved output images look washed out? =====
Line 535: Line 564:
  
 The Darken and Lighten brushes are like the Pixels brush, except that they only copy pixel values if that copy will make the target get darker or lighter, respectively. ​ This is occasionally handy when retouching small isolated features such as the bristles of an insect. The Darken and Lighten brushes are like the Pixels brush, except that they only copy pixel values if that copy will make the target get darker or lighter, respectively. ​ This is occasionally handy when retouching small isolated features such as the bristles of an insect.
 +
 +===== Sometimes I see noise getting added when I retouch. ​ Why is that? =====
 +
 +This effect can occur when you retouch from a PMax output into a DMap output. ​ As explained in [[:​stacker:​docs:​faqlist#​what_is_the_difference_between_pmax_and_dmap|another FAQ]], PMax output is generally noisier than DMap output. ​ Often this difference is overlooked when you are looking at just one or the other, or even side-by-side. ​ But when you retouch from PMax into DMap, the greater noise of PMax is carried over, and that's when it becomes obvious, seen against the quieter surrounding areas made by DMap.
 +
 +There are a couple of ways to reduce this problem. ​ First is to always shoot at the lowest possible ISO, so that your source images will have as little pixel noise as possible. ​ Second is to retouch in the smallest possible areas, typically only where DMap has messed up the handling of front/back overlap between two focused parts of the subject. ​ DMap will almost always give a better rendition of background and of foreground edges seen against unfocused background, so those areas usually should not be retouched from PMax.
 +
 +===== I did not save a project. ​ Can I retouch anyway? =====
 +
 +Yes, in most cases. ​ But the process is cumbersome, so it's better to use File > Save Project and File > Open Project as intended.
 +
 +In detail, the process goes like this:
 +  - Open or re-create a project that has source images in the same alignment that produced the image you want to retouch.
 +  - Go to Options > Preferences > Preprocessing,​ and put a checkmark on the option to "Add files to existing project as already aligned"​.
 +  - Add the image that you want to retouch, into the Input Files panel. ​ You can do this by either drag-and-drop or File > Add File(s).
 +  - Be sure the project has as least one output image. ​ Create one by stacking, if necessary.
 +  - Select any output image.
 +  - Edit > Start Retouching.
 +  - Set scale to "Fit window"​.
 +  - Position the retouching brush in the center of the image, then resize it big enough to cover the entire image at one time.
 +  - Click once, to replace all pixels in the placeholder with pixels from the image that you really want to retouch. ​ The "​Current Retouched Image" will then be equal to the image you want to retouch, just as if it would have been if selected from the Output Images panel.
 +  - Resize the retouching brush to be a normal small size.
 +  - Proceed with retouching as you originally intended.
  
 ===== Do you have a user forum? ===== ===== Do you have a user forum? =====
Line 580: Line 632:
 To locate log and configuration files, proceed as follows: To locate log and configuration files, proceed as follows:
   * On Windows, do a Start > Run on the Windows taskbar. ​ In the little window that pops up, specify to Open: "​%APPDATA%\ZereneStacker"​ (omit the quotes, and no space in the name). ​ Click OK.  This will open a file explorer window showing the ZereneStacker folder in your user area. \\ \\ On Windows 10, usually it is not possible to open the Start > Run dialog. ​ Instead, you can open a File Explorer window, then in that window'​s address bar, type in %APPDATA%\ZereneStacker and hit the Enter key. Searching Windows for %APPDATA%\ZereneStacker will also work.  \\ \\ On some systems, it is also necessary to set the folder view options to "Show hidden files, folders, and drives"​. ​ See for example [[http://​www.windows10themes.net/​guides/​how-to-view-the-appdata-folder-in-windows-10/​]] \\ \\   * On Windows, do a Start > Run on the Windows taskbar. ​ In the little window that pops up, specify to Open: "​%APPDATA%\ZereneStacker"​ (omit the quotes, and no space in the name). ​ Click OK.  This will open a file explorer window showing the ZereneStacker folder in your user area. \\ \\ On Windows 10, usually it is not possible to open the Start > Run dialog. ​ Instead, you can open a File Explorer window, then in that window'​s address bar, type in %APPDATA%\ZereneStacker and hit the Enter key. Searching Windows for %APPDATA%\ZereneStacker will also work.  \\ \\ On some systems, it is also necessary to set the folder view options to "Show hidden files, folders, and drives"​. ​ See for example [[http://​www.windows10themes.net/​guides/​how-to-view-the-appdata-folder-in-windows-10/​]] \\ \\
-  * On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory'​s Library/​Preferences/​ZereneStacker. ​ \\ Note that the required directory is //not// in the /​Library/​Preferences that hangs off the root of your computer'​s disk.  Instead it is the one located in your own home directory, **~**/​Library/​Preferences. ​ In modern versions of Mac OS X ("​Lion"​ and later), your own Library folder is normally hidden in Finder. ​ To see into it, simply click the Go menu in Finder, then press and hold the Option (Alt) key to add Library to the list of available folders (as shown [[http://​osxdaily.com/​2016/​12/​12/​show-user-library-folder-macos-sierra/​|HERE]]). ​ Continue holding the Option key while you click on Library to view its contents, then double-click to open the Preferences folder and then the ZereneStacker folder.+  * On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory'​s Library/​Preferences/​ZereneStacker. ​ \\ Note that the required directory is //not// in the /​Library/​Preferences that hangs off the root of your computer'​s disk.  Instead it is the one located in your own home directory, **~**/​Library/​Preferences. ​ In modern versions of Mac OS X ("​Lion"​ and later), your own Library folder is normally hidden in Finder. ​ To see into it, simply click the Go menu in Finder, then press and hold the Option (Alt) key to add Library to the list of available folders (as shown [[http://​osxdaily.com/​2016/​12/​12/​show-user-library-folder-macos-sierra/​|HERE]]). ​ Continue holding the Option key while you click on Library to view its contents, then double-click to open the Preferences folder and then the ZereneStacker folder. \\ \\ 
 +  * On Linux, navigate to ~/​.ZereneStacker .  That's the normally hidden folder named "​.ZereneStacker",​ hanging off the root of your login account.
  
 Probably the ZereneStacker folder will contain several log files. ​ To identify the proper one, consider the circumstances: ​ If you received a popup diagnostic that said "Uh-oh -- something went wrong and caused an internal error",​ then the file is named something like ErrorLog<​timestamp>​.txt or AutoErrorLog<​timestamp>​.txt,​ where <​timestamp>​ is a string of digits that indicate date & time.  For example the file may be named ErrorLog20110508090456.txt,​ for a problem that occurred on 2011 May 8 at 09:04:56 am.  If you did not receive such a popup, then the log file is LastNormalLog.txt. ​ Probably the ZereneStacker folder will contain several log files. ​ To identify the proper one, consider the circumstances: ​ If you received a popup diagnostic that said "Uh-oh -- something went wrong and caused an internal error",​ then the file is named something like ErrorLog<​timestamp>​.txt or AutoErrorLog<​timestamp>​.txt,​ where <​timestamp>​ is a string of digits that indicate date & time.  For example the file may be named ErrorLog20110508090456.txt,​ for a problem that occurred on 2011 May 8 at 09:04:56 am.  If you did not receive such a popup, then the log file is LastNormalLog.txt. ​
stacker/docs/faqlist.1593457623.txt.gz · Last modified: 2020/06/29 19:07 by rjlittlefield
Copyright 2009-2021, Zerene Systems LLC, all rights reserved.