Zerene Stacker

Slabbing

Slabbing is a technique for making it easier to work with stacks that contain large numbers of images. The concept of slabbing is that you split your stacking into two big steps. In the first big step you might reduce say 200 original source images to 30 intermediate images, by stacking sets of 10-15 photos each, with some overlap between sets. Then in the second big step you stack the 30 intermediate images, the “slab outputs”, to produce an image with the full stack combined.

When you retouch with slabbing, typically you only have to reach back to the intermediate images (the slab outputs), instead of all the way back to each of the original source images. In the example, that means retouching from a set of only 30 images instead of 200.

Slabbing can also be very helpful if you need to explore a variety of settings for the DMap parameters. In this scenario you would generate the slab outputs using the PMax stacking method, then stack the slabs using DMap. The gain here is much faster computation for the stacking, because DMap only needs to work with the much smaller number of slab outputs, instead of all the original source images individually.

Historically, slabbing has been accomplished by using some third-party program to generate a batch script to control the slabbing. Examples of such programs include ZereneVS, Slabberjockey, BugSlabber, and MakeSubStackingScript. Those worked great for a long time, but recent improvements in Apple's macOS security have had the unfortunate side effect of making the third-party programs difficult or impossible to use on Mac computers.

So, the current production build of Zerene Stacker now provides slabbing as a built-in function.

In more detail, here is one possible workflow with slabbing:

  • Launch Zerene Stacker, load source files, and File > Save Project.
  • Click on Batch > Slabbing… to open the Slabbing panel of the Preferences dialog.
  • In the Slabbing panel, adjust the slab size and overlap as desired.
    (Note that the Preferences > Slab Saving panel can only be reached when the Preferences panel is opened through Batch > Slabbing. Otherwise that slot is occupied by the normal Image Saving parameters.)
  • Click OK to close the Preferences dialog. This results in silently constructing a bunch of batch tasks to create the slabs.
  • In the menu bar, click on Batch > Show Batch Dialog. You should see one batch of tasks, one task per slab.
  • Run All Batches.
  • Be sure that there's a checkmark on Options > Preferences > Preprocessing > “Add files to existing project as already aligned”.
  • Look into the SavedImages subfolder of the project.
  • Select the slab outputs.
  • Drag those into the Zerene Stacker Input Files List.
  • Select all the newly added images (the slab outputs).
  • Stack > Stack Selected. At this stage you are combining the slab outputs to produce a whole stack output.
  • File > Save Project. (Always save your work, so you don't have to restart from the beginning if something goes horribly wrong.)
  • Retouch as needed.

One caution: if you interrupt the batch script while slabbing is being done, then the output image naming template may be left as something like “Slab {outseq} PMax”, rather than its default value of “{datetime} ZS {method}” or whatever else you had it set to. This can result in some confusion, as then subsequent normal outputs will be named as if they were slabs. This behavior is on the list of bugs to be fixed in a subsequent release. Until that happens, please check and reset the value of the output naming template if you need to interrupt the slabbing process. It is located at Options > Preferences > Image Saving > Template.

stacker/docs/slabbing.txt · Last modified: 2020/06/13 03:31 by rjlittlefield
Copyright 2009-2020, Zerene Systems LLC, all rights reserved.